载入中...
在线检测未来函数
载入中...

通达信黄龙选股指标公式

来源:Internet,编辑:股旁网,2019-12-02

MA5:=MA(C,5);
MA10:=MA(C,10);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
VAR1:=MA120>MA60 AND MA60>MA30;
VAR2:=MA30>MA60 AND MA60>MA120;
VAR3:=MAX(MA30,MAX(MA60,MA120));
VAR4:=MIN(MA30,MIN(MA60,MA120));
VAR5:=IF(MA30<>VAR3 AND MA30<>VAR4,MA30,IF(MA60<>VAR3 AND MA60<>VAR4,MA60,MA120));
VAR6:=(VAR3-VAR4)/VAR4*100;
VAR7:=(VAR5-VAR4)/VAR4*100;
VAR8:=MA(REF(HHV(C,30),1),2);
VAR9:=MA(REF(LLV(C,30),1),2);
VAR10:=(VAR8-MAX(C,O))/MAX(C,O)*100;
VAR11:=(MIN(C,O)-VAR9)/VAR9*100;
VAR12:=BARSLASTCOUNT(VAR9<REF(VAR9,1) AND VAR9*1.007>=REF(VAR9,1));
VAR13:=(MAX(C,O)-MIN(C,O))/MIN(C,O)*100;
VAR14:=(H-MAX(C,O))/MAX(C,O)*100;
VAR15:=(MIN(C,O)-L)/L*100;
VAR16:=BARSLASTCOUNT(MAX(O,C)<=REF(MAX(O,C),1) AND MIN(O,C)<=REF(MIN(O,C),1))>=2;
VAR17:=(REF(MIN(C,O),1)-MAX(C,O))/MAX(C,O)*100;
VAR18:=(BARSLASTCOUNT(VAR13>2.1)>=3 AND BARSLASTCOUNT(VAR17>2.1)>=2 AND COUNT(VAR17>5.5,2)) OR (BARSLASTCOUNT(OPEN<REF(OPEN,1) AND C<REF(C,1))=2 AND BARSLASTCOUNT(OPEN>C AND VAR13>4)=3);
VAR19:=RANGE(MIN(C,O),MA(C,5)*0.98,MA(C,5)*1.02);
VAR20:=(MAX(HHV(C,10),HHV(OPEN,10))-MIN(LLV(C,10),LLV(OPEN,10)))/MIN(LLV(C,10),LLV(OPEN,10))*100;
VAR21:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR22:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VAR23:=REF(VAR22,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR24:=REF(VAR22 OR VAR23,1) AND VAR21;
VAR25:=VAR24 AND CLOSE>OPEN;
VAR26:=REF(VAR21,1) AND VAR22 AND NOT(REF(C,3)=LLV(C,4));
VAR27:=(CLOSE/OPEN)>1.04 AND CLOSE<SMA(HIGH,19,3) AND C>REF(C,1);
VAR28:=IF(C>MA(C,4),1,0)+IF(C<MA(C,4),-1,0)+IF(MA(C,5)>REF(MA(C,5),1),1,0)+IF(MA(C,5)<REF(MA(C,5),1),-1,0);
VAR29:=VAR28=-2 AND C>O;
VAR30:=IF(C>MA(C,4),1,0);
VAR31:=IF(C<MA(C,4),-1,0);
VAR32:=IF(MA(C,5)>REF(MA(C,5),1),1,0);
VAR33:=IF(MA(C,5)<REF(MA(C,5),1),-1,0);
VAR34:=VAR30+VAR31+VAR32+VAR33;
VAR35:=VAR34=2 AND C<O;
VAR36:= EMA((CLOSE*2+HIGH+LOW)/4,13)-EMA((CLOSE*2+HIGH+LOW)/4,73);
VAR37:=(CROSS(VAR36,EMA(VAR36,2)) AND VAR36<=0.05 AND (C/REF(C,1)>0.035));
VAR38:=VAR37 AND NOT(VAR35);
VAR39:=VAR27 AND VAR13>3.9 AND VAR11<0.2 AND C>VAR9 AND VAR15<1.5 AND REF(VAR14<3,1) AND (REF(VAR13>5.5 AND C<OPEN,1) AND REF(VAR13,1)>VAR13)=0 AND VAR38=0 AND VAR29=0 AND REF(VAR26 AND VAR38 AND VAR25=0,1)=0 AND REF(VAR25=0,2);
VAR40:=(VAR9=REF(VAR9,1) OR VAR12) AND C<VAR4*1.01 AND BARSLASTCOUNT(VAR4<=REF(VAR4,1))>=7 AND VAR7<11.54 AND ((BARSLASTCOUNT(VAR3>VAR8)>=4 AND OPEN<VAR9) OR (BARSLASTCOUNT(VAR3<VAR8)>10 AND OPEN>VAR9 AND VAR6<10)) AND (VAR1 OR C*1.2<VAR4 OR COUNT(CROSS(MA30,MA60),4)) AND BARSLASTCOUNT(VAR5<VAR8)>=7;
VAR41:=VAR39 AND VAR40;
VAR42:=VAR27 AND VAR13>5.4 AND C=HHV(C,4) AND OPEN<=REF(MAX(C,O),1) AND VAR14<1.7 AND VAR38=0 AND VAR29=0 AND (REF(BARSLASTCOUNT(VAR13<1.5 AND VAR19)>=3,1) OR REF(COUNT(VAR16,2)>=1 AND BARSLASTCOUNT(VAR13>1.5)>=3,1)) AND (REF(VAR13>4.5 AND C<OPEN,1)=0 OR REF(VAR18,1));
VAR43:=VAR11<5.4 AND VAR10<14 AND C>VAR9 AND C<VAR3*1.01 AND C>VAR4 AND BARSLASTCOUNT(VAR3<VAR8)>10 AND (COUNT(VAR18,7) OR REF(VAR20<10,1)) AND (VAR2 OR BARSLASTCOUNT(VAR3>=REF(VAR3,1))>=10);
VAR44:=VAR42 AND VAR43;
VAR45:=(VAR16 AND BARSLASTCOUNT(VAR13<2.5)>=3 AND VAR29 AND C<VAR9) OR VAR18;
VAR46:=(BARSLASTCOUNT(C>0)<60 AND C<MA30*1.01 AND CROSS(C,MA5) AND CROSS(C,MA10)) OR (VAR13>5 AND VAR10<14);
VAR47:=VAR27 AND VAR13>3.9 AND VAR11<1.05 AND C>VAR9 AND C<MA30 AND REF(VAR9,1)>REF(VAR9,2) AND VAR9<REF(VAR9,1) AND REF(VAR45,1) AND VAR46;
黄龙:VAR41 OR VAR44 OR VAR47;

通达信黄龙选股指标公式

 

通达信黄龙选股指标公式的选股公式如下:

相关文章