载入中...
在线检测未来函数
载入中...

聪明买卖主图之买选股指标公式

来源:Internet,编辑:股旁网,2019-11-29

短:=WMA(EXPMA(((3*C)+(2*O)+H+L)/7,3),3);
道:=IF(1,SMA(短,8,1),DRAWNULL);
神线1:=MA(C,20)-MA(C,250);
神线2:=MA(C,60)-MA(C,250);
神功1:=MA(神线1,1)*4;
神功2:=EMA(神线2,1)*4;
YS1:=(HIGH+LOW+CLOSE*2)/4;
RK3:=EMA(YS1,10);
RK4:=STD(YS1,10);
RK5:=(YS1-RK3)*100/RK4;
RK6:=EMA(RK5,5);
RK7:=EMA(RK6,10);
涨:=EMA(RK6,10)+100/2-5;
股灾2:=NOT(REF(C<O,1) AND C<REF(H,1) );
股灾3:=NOT(C<REF(H,1) AND C<REF(H,2) OR C<REF(H,3) OR C<REF(H,4) OR C<REF(H,5));
股灾4:=NOT(COUNT(C<O,7) >=5 AND SUM(C/REF(C,1)<0.96,7)>=1);
股灾5:=NOT( 道<MA(C,60) AND MA(C,60)<REF(MA(C,60),1) AND C<MA(C,60) );
股灾6:=NOT(道<REF(道,1) AND C<道);
股灾7:=SUM(SUM(C/REF(C,1)>1.099,7)>=5 AND C>MA(C,250),60)<1;
股灾8:=SUM(HHVBARS(HIGH,90)>LLVBARS(HIGH,90) AND (HHV( HIGH,90)-LLV( LOW,90))/LLV( LOW,90)*100>50 AND C>MA(C,250) ,90) <1;
股灾9:=NOT(MA(C,5)<MA(C,10) AND MA(C,10)<MA(C,20) AND MA(C,20)<MA(C,30) AND MA(C,20)<MA(C,120) AND MA(C,120)<MA(C,90) AND MA(C,20)<REF(MA(C,20),1) AND MA(C,30)<REF(MA(C,30),1) AND MA(C,60)<REF(MA(C,60),1) ) ;
股灾12:=SUM((C/REF(C,1)<0.91 AND L=C),30)<1;
股灾13:=SUM((C/REF(C,1))<0.93,10)<1;
股灾15:=NOT( MA(C,10)<MA(C,20) AND MA(C,20)<MA(C,30) AND MA(C,30)<MA(C,60) AND MA(C,10)<REF(MA(C,10),1) AND MA(C,20)<REF(MA(C,20),1) AND MA(C,30)<REF(MA(C,30),1) AND MA(C,120)>MA(C,250) AND MA(C,90)>MA(C,120) AND O<MA(C,120) AND C<MA(C,20) ) ;
股灾总:=股灾2 AND 股灾3 AND 股灾4 AND 股灾5 AND 股灾6 AND 股灾7 AND 股灾8 AND 股灾9 AND 股灾12 AND 股灾13 AND 股灾15;
P1:=涨>REF(涨,1) AND REF(涨,1)<REF(涨,2) AND H>MA(C,250) AND MA(C,10)>MA(C,250) AND MA(C,20)>MA(C,250) AND MA(C,250)>REF(MA(C,250),1) AND LLV(C,15)<MA(C,250) AND 股灾13 AND C>O;
P2:=涨>REF(涨,1) AND REF(涨,1)<REF(涨,2) AND MA(C,10)>MA(C,250) AND MA(C,20)>MA(C,250) AND MA(C,250)>REF(MA(C,250),1) AND MA(C,120)>REF(MA(C,120),1) AND LLV(C,15)<MA(C,120) AND C>O AND C>MA(C,120) AND 股灾12 AND 股灾15 AND 股灾9;
P3:=涨>REF(涨,1) AND REF(涨,1)<REF(涨,2) AND H>MA(C,60) AND MA(C,10)>MA(C,250) AND MA(C,20)>MA(C,250) AND MA(C,250)>REF(MA(C,250),1) AND MA(C,20)>REF(MA(C,20),1) AND MA(C,90)>REF(MA(C,90),1) AND C>MA(C,20) AND C>O AND C/REF(C,1)<1.099 AND LLV(C,5)<MA(C,120);
P4:=涨>REF(涨,1) AND REF(涨,1)<REF(涨,2) AND H>MA(C,20) AND MA(C,20)>MA(C,60) AND MA(C,60)>MA(C,120) AND MA(C,120)>MA(C,250) AND MA(C,250)>REF(MA(C,250),1) AND MA(C,20)>REF(MA(C,20),1) AND MA(C,60)>REF(MA(C,60),1) AND C>MA(C,20) AND C>O AND NOT(REF(C,1)/REF(C,2)<0.97) AND LLV(C,5)<MA(C,20) AND REF(C,1)/REF(C,2)<1.099 AND SUM(C<=O,7)<5 AND C>神功2 AND 神功2>REF(神功2,1)+0.01 AND ABS(MA(C,10)-MA(C,20))>ABS(MA(C,10)-MA(C,30));
P5:=涨>REF(涨,1) AND REF(涨,1)<REF(涨,2) AND MA(C,10)>MA(C,250) AND MA(C,20)>MA(C,250) AND MA(C,250)>REF(MA(C,250),1) AND MA(C,120)>REF(MA(C,120),1) AND LLV(C,15)<MA(C,120) AND C>O AND C>MA(C,250) AND C<MA(C,120) AND 股灾12 AND 股灾15 AND 股灾9;
停牌:=NOT(NAMELIKE('ST') AND NAMELIKE('*ST') OR NAMELIKE('S')) AND (BARSCOUNT(C)+1)>30 AND DYNAINFO(10)>100;
选:=P1 OR P2 OR P3 OR P4 OR P5 AND 停牌 AND 股灾总;
买:选 AND SUM(选,10)<2;

聪明买卖主图之买选股指标公式

 

上述选股公式根据以下股票指标公式改编:
http://www.gupang.net/201911/11294Z412019.html

相关文章