载入中...
在线检测未来函数
载入中...

通达信聪明买卖主图指标公式

来源:Internet,编辑:股旁网,2019-11-29

N:=150;
VAR1:=EMA(EMA(EMA(C,5),8),13);
VAR2:=((VAR1-REF(VAR1,1))/REF(VAR1,1))*618;
VAR3:=MA(VAR2,8);
VAR4:=VAR2-VAR3;
VAR5:=SMA(VAR4,3,1);
短:WMA(EXPMA(((3*C)+(2*O)+H+L)/7,3),3),COLORFFFFFF;
道:IF(1,SMA(短,8,1),DRAWNULL),COLORCC99AA,LINETHICK2;
IF(VAR2>=VAR3,道,DRAWNULL),COLOR6600CC,LINETHICK2;
VARC:=BARSLAST(VAR4>=REF(VAR4,1));
VARD:=BARSLAST(VAR4<=REF(VAR4,1));
神10:MA(C,10);
神30:=MA(C,30);
神60:MA(C,60);
神120:MA(C,120);
神250:MA(C,250);
STICKLINE(VARC=0 AND C>MA(C,250) AND C>MA(C,20) AND C>MA(C,60) AND C>MA(C,160) AND C<O,H,L,0,0),COLORFFCC00;
STICKLINE(VARC=0 AND C>MA(C,250) AND C>MA(C,20) AND C>MA(C,60) AND C>MA(C,160) AND C>O,H,L,0,0),COLOR0000FF;
STICKLINE(VARC=0 AND C>MA(C,250) AND C>MA(C,20) AND C>MA(C,60) AND C>MA(C,160),C,O,4 ,0 ),COLOR0000AA;
STICKLINE(VARC=0 AND C>MA(C,250) AND C>MA(C,20) AND C>MA(C,60) AND C>MA(C,160),C,O,3.3 ,0 ),COLOR0011BB;
STICKLINE(VARC=0 AND C>MA(C,250) AND C>MA(C,20) AND C>MA(C,60) AND C>MA(C,160),C,O,2.2,0 ),COLOR0022CC;
STICKLINE(VARC=0 AND C>MA(C,250) AND C>MA(C,20) AND C>MA(C,60) AND C>MA(C,160),C,O,1.65 ,0 ),COLOR0033DD;
STICKLINE(VARC=0 AND C>MA(C,250) AND C>MA(C,20) AND C>MA(C,60) AND C>MA(C,160),C,O,1.1 ,0 ),COLOR0044EE;
STICKLINE(VARC=0 AND C>MA(C,250) AND C>MA(C,20) AND C>MA(C,60) AND C>MA(C,160),C,O,0.55 ,0 ),COLOR0055FF;
STICKLINE(VARC=0 AND C<MA(C,250) AND C>O ,H,L,0,0),COLOR0000FF;
STICKLINE(VARC=0 AND C<MA(C,250) AND C<O ,H,L,0,0),COLORFFCC00;
STICKLINE(VARC=0 AND C<MA(C,250),C,O,0,0),COLORFF9900;
STICKLINE(VARC=0 AND C<MA(C,250),CLOSE,OPEN,3,0),COLORFF5500;
STICKLINE(VARC=0 AND C<MA(C,250),CLOSE,OPEN,2.8,0),COLORFF6600;
STICKLINE(VARC=0 AND C<MA(C,250),CLOSE,OPEN,2.5,0),COLORFF7700;
STICKLINE(VARC=0 AND C<MA(C,250),CLOSE,OPEN,2.2,0),COLORFF8800;
STICKLINE(VARC=0 AND C<MA(C,250),CLOSE,OPEN,1.7,0),COLORFF9900;
STICKLINE(VARC=0 AND C<MA(C,250),CLOSE,OPEN,1.2,0),COLORFFAA00;
STICKLINE(VARC=0 AND C<MA(C,250),CLOSE,OPEN,0.7,0),COLORFFCC00;
STICKLINE(VARC=0 AND C<MA(C,250),CLOSE,OPEN,0.2,0),COLORFFFF00;
STICKLINE(VARC=0 AND C<MA(C,20) AND C>O ,H,L,0,0),COLOR0000FF;
STICKLINE(VARC=0 AND C<MA(C,20) AND C<O ,H,L,0,0),COLORFFCC00;
STICKLINE(VARC=0 AND C<MA(C,20),C,O,0,0),COLORFF9900;
STICKLINE(VARC=0 AND C<MA(C,20),CLOSE,OPEN,3,0),COLORFF5500;
STICKLINE(VARC=0 AND C<MA(C,20),CLOSE,OPEN,2.8,0),COLORFF6600;
STICKLINE(VARC=0 AND C<MA(C,20),CLOSE,OPEN,2.5,0),COLORFF7700;
STICKLINE(VARC=0 AND C<MA(C,20),CLOSE,OPEN,2.2,0),COLORFF8800;
STICKLINE(VARC=0 AND C<MA(C,20),CLOSE,OPEN,1.7,0),COLORFF9900;
STICKLINE(VARC=0 AND C<MA(C,20),CLOSE,OPEN,1.2,0),COLORFFAA00;
STICKLINE(VARC=0 AND C<MA(C,20),CLOSE,OPEN,0.7,0),COLORFFCC00;
STICKLINE(VARC=0 AND C<MA(C,20),CLOSE,OPEN,0.2,0),COLORFFFF00;
STICKLINE(VARC=0 AND C<MA(C,60) AND C>O ,H,L,0,0),COLOR0000FF;
STICKLINE(VARC=0 AND C<MA(C,60) AND C<O,H,L,0,0),COLORFFCC00;
STICKLINE(VARC=0 AND C<MA(C,60),C,O,0,0),COLORFF9900;
STICKLINE(VARC=0 AND C<MA(C,60),CLOSE,OPEN,3,0),COLORFF5500;
STICKLINE(VARC=0 AND C<MA(C,60),CLOSE,OPEN,2.8,0),COLORFF6600;
STICKLINE(VARC=0 AND C<MA(C,60),CLOSE,OPEN,2.5,0),COLORFF7700;
STICKLINE(VARC=0 AND C<MA(C,60),CLOSE,OPEN,2.2,0),COLORFF8800;
STICKLINE(VARC=0 AND C<MA(C,60),CLOSE,OPEN,1.7,0),COLORFF9900;
STICKLINE(VARC=0 AND C<MA(C,60),CLOSE,OPEN,1.2,0),COLORFFAA00;
STICKLINE(VARC=0 AND C<MA(C,60),CLOSE,OPEN,0.7,0),COLORFFCC00;
STICKLINE(VARC=0 AND C<MA(C,60),CLOSE,OPEN,0.2,0),COLORFFFF00;
STICKLINE(VARC=0 AND C<MA(C,160) AND C>O,H,L,0,0),COLOR0000FF;
STICKLINE(VARC=0 AND C<MA(C,160) AND C<O,H,L,0,0),COLORFFCC00;
STICKLINE(VARC=0 AND C<MA(C,160) ,C,O,0,0),COLORFF9900;
STICKLINE(VARC=0 AND C<MA(C,160) ,CLOSE,OPEN,3,0),COLORFF5500;
STICKLINE(VARC=0 AND C<MA(C,160) ,CLOSE,OPEN,2.8,0),COLORFF6600;
STICKLINE(VARC=0 AND C<MA(C,160) ,CLOSE,OPEN,2.5,0),COLORFF7700;
STICKLINE(VARC=0 AND C<MA(C,160) ,CLOSE,OPEN,2.2,0),COLORFF8800;
STICKLINE(VARC=0 AND C<MA(C,160) ,CLOSE,OPEN,1.7,0),COLORFF9900;
STICKLINE(VARC=0 AND C<MA(C,160) ,CLOSE,OPEN,1.2,0),COLORFFAA00;
STICKLINE(VARC=0 AND C<MA(C,160) ,CLOSE,OPEN,0.7,0),COLORFFCC00;
STICKLINE(VARC=0 AND C<MA(C,160) ,CLOSE,OPEN,0.2,0),COLORFFFF00;
STICKLINE(VARD=0 AND C>O,H,L,0,0),COLOR0000FF;
STICKLINE(VARD=0 AND C<O,H,L,0,0),COLORFFCC00;
STICKLINE(VARD=0,C,O,0,0),COLORFF9900;
STICKLINE(VARD=0,CLOSE,OPEN,3,0),COLORFF5500;
STICKLINE(VARD=0,CLOSE,OPEN,2.8,0),COLORFF6600;
STICKLINE(VARD=0,CLOSE,OPEN,2.5,0),COLORFF7700;
STICKLINE(VARD=0,CLOSE,OPEN,2.2,0),COLORFF8800;
STICKLINE(VARD=0,CLOSE,OPEN,1.7,0),COLORFF9900;
STICKLINE(VARD=0,CLOSE,OPEN,1.2,0),COLORFFAA00;
STICKLINE(VARD=0,CLOSE,OPEN,0.7,0),COLORFFCC00;
STICKLINE(VARD=0,CLOSE,OPEN,0.2,0),COLORFFFF00;
STICKLINE(VARD=0 AND H>MA(C,5) AND C>MA(C,250) AND C>MA(C,60) AND C>MA(C,160) AND MA(C,5)>MA(C,20) AND C>O,H,L,0,0),COLOR0000FF;
STICKLINE(VARD=0 AND H>MA(C,5) AND C>MA(C,250) AND C>MA(C,60) AND C>MA(C,160) AND MA(C,5)>MA(C,20) AND C<O,H,L,0,0),COLORFFCC00;
STICKLINE(VARD=0 AND H>MA(C,5) AND C>MA(C,250) AND C>MA(C,60) AND C>MA(C,160) AND MA(C,5)>MA(C,20),C,O,0,0),COLOR0088EE;
STICKLINE(VARD=0 AND H>MA(C,5) AND C>MA(C,250) AND C>MA(C,60) AND C>MA(C,160) AND MA(C,5)>MA(C,20),C,O,4 ,0 ),COLOR0000AA;
STICKLINE(VARD=0 AND H>MA(C,5) AND C>MA(C,250) AND C>MA(C,60) AND C>MA(C,160) AND MA(C,5)>MA(C,20),C,O,3.3 ,0 ),COLOR0011BB;
STICKLINE(VARD=0 AND H>MA(C,5) AND C>MA(C,250) AND C>MA(C,60) AND C>MA(C,160) AND MA(C,5)>MA(C,20),C,O,2.2,0 ),COLOR0022CC;
STICKLINE(VARD=0 AND H>MA(C,5) AND C>MA(C,250) AND C>MA(C,60) AND C>MA(C,160) AND MA(C,5)>MA(C,20),C,O,1.65 ,0 ),COLOR0033DD;
STICKLINE(VARD=0 AND H>MA(C,5) AND C>MA(C,250) AND C>MA(C,60) AND C>MA(C,160) AND MA(C,5)>MA(C,20),C,O,1.1 ,0 ),COLOR0044EE;
STICKLINE(VARD=0 AND H>MA(C,5) AND C>MA(C,250) AND C>MA(C,60) AND C>MA(C,160) AND MA(C,5)>MA(C,20),C,O,0.55 ,0 ),COLOR0055FF;
情3:=VARC=0 AND C>MA(C,20) AND (BARSCOUNT(C)+1)<365 ;
STICKLINE(情3 AND C>O,H,L,0,0),COLOR0000FF;
STICKLINE(情3 AND C<O,H,L,0,0),COLORFFCC00;
STICKLINE(情3,C,O,-1,0),COLOR001235;
STICKLINE(情3 AND C<O,H,L,0,0),COLORFFCC00;
STICKLINE(情3 AND C>O,H,L,0,0),COLOR0000FF;
STICKLINE(情3,C,O,4 ,0 ),COLOR0000AA;
STICKLINE(情3,C,O,3.3 ,0 ),COLOR0011BB;
STICKLINE(情3,C,O,2.2,0 ),COLOR0022CC;
STICKLINE(情3,C,O,1.65 ,0 ),COLOR0033DD;
STICKLINE(情3,C,O,1.1 ,0 ),COLOR0044EE;
STICKLINE(情3,C,O,0.55 ,0 ),COLOR0055FF;
神线1:=MA(C,20)-MA(C,250);
神线2:=MA(C,60)-MA(C,250);
神功1:=MA(神线1,1)*4;
神功2:=EMA(神线2,1)*4,COLORFFFF80;
YS1:=(HIGH+LOW+CLOSE*2)/4;
RK3:=EMA(YS1,10);
RK4:=STD(YS1,10);
RK5:=(YS1-RK3)*100/RK4;
RK6:=EMA(RK5,5);
RK7:=EMA(RK6,10);
涨:=EMA(RK6,10)+100/2-5,COLORRED;
股灾2:=NOT(REF(C<O,1) AND C<REF(H,1) );
股灾3:=NOT(C<REF(H,1) AND C<REF(H,2) OR C<REF(H,3) OR C<REF(H,4) OR C<REF(H,5));
股灾4:=NOT(COUNT(C<O,7) >=5 AND SUM(C/REF(C,1)<0.96,7)>=1);
股灾5:=NOT( 道<MA(C,60) AND MA(C,60)<REF(MA(C,60),1) AND C<MA(C,60) );
股灾6:=NOT(道<REF(道,1) AND C<道);
股灾7:=SUM(SUM(C/REF(C,1)>1.099,7)>=5 AND C>MA(C,250),60)<1;
股灾8:=SUM(HHVBARS(HIGH,90)>LLVBARS(HIGH,90) AND (HHV( HIGH,90)-LLV( LOW,90))/LLV( LOW,90)*100>50 AND C>MA(C,250) ,90) <1;
股灾9:=NOT(MA(C,5)<MA(C,10) AND MA(C,10)<MA(C,20) AND MA(C,20)<MA(C,30) AND MA(C,20)<MA(C,120) AND MA(C,120)<MA(C,90) AND MA(C,20)<REF(MA(C,20),1) AND MA(C,30)<REF(MA(C,30),1) AND MA(C,60)<REF(MA(C,60),1) ) ;
股灾12:=SUM((C/REF(C,1)<0.91 AND L=C),30)<1;
股灾13:=SUM((C/REF(C,1))<0.93,10)<1;
股灾15:=NOT( MA(C,10)<MA(C,20) AND MA(C,20)<MA(C,30) AND MA(C,30)<MA(C,60) AND MA(C,10)<REF(MA(C,10),1) AND MA(C,20)<REF(MA(C,20),1) AND MA(C,30)<REF(MA(C,30),1) AND MA(C,120)>MA(C,250) AND MA(C,90)>MA(C,120) AND O<MA(C,120) AND C<MA(C,20) ) ;
股灾总:=股灾2 AND 股灾3 AND 股灾4 AND 股灾5 AND 股灾6 AND 股灾7 AND 股灾8 AND 股灾9 AND 股灾12 AND 股灾13 AND 股灾15;
P1:=涨>REF(涨,1) AND REF(涨,1)<REF(涨,2) AND H>MA(C,250) AND MA(C,10)>MA(C,250) AND MA(C,20)>MA(C,250) AND MA(C,250)>REF(MA(C,250),1) AND LLV(C,15)<MA(C,250) AND 股灾13 AND C>O;
P2:=涨>REF(涨,1) AND REF(涨,1)<REF(涨,2) AND MA(C,10)>MA(C,250) AND MA(C,20)>MA(C,250) AND MA(C,250)>REF(MA(C,250),1) AND MA(C,120)>REF(MA(C,120),1) AND LLV(C,15)<MA(C,120) AND C>O AND C>MA(C,120) AND 股灾12 AND 股灾15 AND 股灾9;
P3:=涨>REF(涨,1) AND REF(涨,1)<REF(涨,2) AND H>MA(C,60) AND MA(C,10)>MA(C,250) AND MA(C,20)>MA(C,250) AND MA(C,250)>REF(MA(C,250),1) AND MA(C,20)>REF(MA(C,20),1) AND MA(C,90)>REF(MA(C,90),1) AND C>MA(C,20) AND C>O AND C/REF(C,1)<1.099 AND LLV(C,5)<MA(C,120);
P4:=涨>REF(涨,1) AND REF(涨,1)<REF(涨,2) AND H>MA(C,20) AND MA(C,20)>MA(C,60) AND MA(C,60)>MA(C,120) AND MA(C,120)>MA(C,250) AND MA(C,250)>REF(MA(C,250),1) AND MA(C,20)>REF(MA(C,20),1) AND MA(C,60)>REF(MA(C,60),1) AND C>MA(C,20) AND C>O AND NOT(REF(C,1)/REF(C,2)<0.97) AND LLV(C,5)<MA(C,20) AND REF(C,1)/REF(C,2)<1.099 AND SUM(C<=O,7)<5 AND C>神功2 AND 神功2>REF(神功2,1)+0.01 AND ABS(MA(C,10)-MA(C,20))>ABS(MA(C,10)-MA(C,30));
P5:=涨>REF(涨,1) AND REF(涨,1)<REF(涨,2) AND MA(C,10)>MA(C,250) AND MA(C,20)>MA(C,250) AND MA(C,250)>REF(MA(C,250),1) AND MA(C,120)>REF(MA(C,120),1) AND LLV(C,15)<MA(C,120) AND C>O AND C>MA(C,250) AND C<MA(C,120) AND 股灾12 AND 股灾15 AND 股灾9;
停牌:=NOT(NAMELIKE('ST') AND NAMELIKE('*ST') OR NAMELIKE('S')) AND (BARSCOUNT(C)+1)>30 AND DYNAINFO(10)>100;
选:=P1 OR P2 OR P3 OR P4 OR P5 AND 停牌 AND 股灾总;
STICKLINE(选 AND SUM(选,10)<2,L,L-0.01,3,0) ,COLORYELLOW;
DRAWTEXT( 选 AND SUM(选,10)<2,L-0.02,'↖买'),COLOR00FFFF;

通达信聪明买卖主图指标公式

通达信聪明买卖主图指标公式的选股公式如下:

http://www.gupang.net/201911/49049.html

相关文章