载入中...
在线检测未来函数
载入中...

通达信财源滚滚来主图指标公式

来源:Internet,编辑:股旁网,2019-11-06

生命线:MA(CLOSE,26),COLORRED,LINETHICK2;
STICKLINE(C>=生命线 AND C>=O,H,L,0,1),COLORRED;
STICKLINE(C>=生命线 AND C>=O,C,O,2.5,0),COLORRED;
DP:=IF(C=INDEXC,0,1);GJ:=AMOUNT/V/100 ;
多头线:EMA(C,1.5),COLOR0000CC;
空头线:EMA(C,5),COLORMAGENTA;
均衡线:EMA(空头线,5),COLORGREEN;
TC1:=IF(H=HHV(H,48),H,DRAWNULL);
TC2:=CONST(BARSLAST(TC1=H))+1;
UPPER:=CONST(IF(TC2=1,H,REF(H,TC2-1)));
BC1:=IF(L=LLV(L,48),L,DRAWNULL);
BC2:=CONST(BARSLAST(BC1=L))+1;
LOWER:=CONST(IF(BC2=1,L,REF(L,BC2-1)));
LP:=CURRBARSCOUNT<=BC2 AND L=LOWER;
HP:=CURRBARSCOUNT<=TC2 AND H=UPPER;
AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/
(HHV(HIGH,30)-LLV(LOW,30))*100,8);
BA1:=EMA(AB,5);
上轨:=REFDATE(REF(HHV(MAX(C,O),96),5),DATE);
下轨:=REFDATE(REF(LLV(MIN(C,O),96),5),DATE);
中轨:=((上轨)+(下轨))/2;
YXHX:=DATE>=REF(DATE,BARSLAST(IF(BC2>TC2,LP,HP)));
上沿:IF(AB>0 AND AB-BA1<=0 AND YXHX,上轨,上轨),COLORRED;
中枢:IF(AB>0 AND AB-BA1<=0 AND YXHX,中轨,中轨),COLORRED;
下沿:IF(AB>0 AND AB-BA1<=0 AND YXHX,下轨,下轨),COLORRED;
极限底部:REFDATE(LLV(L,130),DATE)COLORYELLOW;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORYELLOW;
X1:=(C+L+H)/1.5;
X2:=EMA(X1,3);
X3:=EMA(X2,2.5);
DRAWICON(CROSS(X2,X3),L*0.98,9),COLORRED;
STICKLINE(X2>=X3,LOW,HIGH,0,1),COLORRED;
STICKLINE(X2>=X3,CLOSE,OPEN,3.2,2),COLORRED;
STICKLINE(X2<X3,LOW,HIGH,0,1),COLOR00FF00;
STICKLINE(X2<X3,CLOSE,OPEN,3.2,2),COLOR00FF00;
STICKLINE(CROSS(X3,X2),OPEN,CLOSE,3.2,0),COLOR00FF00;
STICKLINE(CROSS(X2,X3),OPEN,CLOSE,3.2,0),COLORRED;
STICKLINE((CLOSE>OPEN) AND (X2<X3),CLOSE,OPEN,3.2,2)COLOR00FF00;
STICKLINE((CLOSE>OPEN) AND (X2>=X3),CLOSE,OPEN,3.2,2)COLORRED;
STICKLINE((CLOSE<OPEN) AND (X2<X3),CLOSE,OPEN,3.2,0)COLOR00FF00;
STICKLINE((CLOSE<OPEN) AND (X2>=X3),CLOSE,OPEN,3.2,0)COLORRED;

通达信财源滚滚来主图指标公式

 

相关文章