载入中...
在线检测未来函数
载入中...

通达信谷式量指标公式

来源:Internet,编辑:股旁网,2019-11-06

M1:=5;
M2:=10;
M3:=20;
M4:=60;
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:IF((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
MAVOL5:MA(VOLUME,M1)COLORWHITE;
MAVOL10:MA(VOLUME,M2)COLORYELLOW;
MAVOL20:MA(VOLUME,M3)COLORFF00FF;
MAVOL60:MA(VOLUME,M4)COLORGREEN;
STICKLINE(VOL>1.8*REF(VOL,1),0,VOL,2,0),COLORYELLOW;
红太阳:=IF(LOW>REF(HIGH,1) AND COUNT(OPEN<CLOSE,1),1,0);
STICKLINE(红太阳=1,V,0,0.5,0),COLORRED;
所属行业:DRAWTEXT_FIX(ISLASTBAR ,0.01,0,0,HYBLOCK),COLORYELLOW;
所属概念:DRAWTEXT_FIX(ISLASTBAR,0.15,0,0,GNBLOCK),COLORYELLOW;
DRAWICON(CROSS(MAVOL5,MAVOL10),MAVOL10,1); {K上穿D做记号};
DRAWICON(CROSS(MAVOL10,MAVOL5),MAVOL5,2); {D下穿K做记号};
T:=DYNAINFO(8)>0;
VO:=VOL=LLV(VOL,8) AND T;
地量柱:T AND VO,COLORBLUE;
STICKLINE(地量柱,0,V,1,0),COLORBLUE;
DRAWTEXT(CURRBARSCOUNT=5+1,V*1.05,'5');
DRAWTEXT(CURRBARSCOUNT=10+1,V*1.05,'10');
DRAWTEXT(CURRBARSCOUNT=20+1,V*1.05,'20');
DRAWTEXT(CURRBARSCOUNT=60+1,V*1.05,'60');
DRAWTEXT(CURRBARSCOUNT=120+2,V*1.05,'120');
DRAWTEXT(CURRBARSCOUNT=240+1,V*1.05,'240');

通达信谷式量指标公式

 

相关文章