载入中...
在线检测未来函数
载入中...

通达信筹码密集分布主图指标公式

来源:Internet,编辑:股旁网,2019-10-18

HB:=COST(99.99);
LB:=COST(0.01);
B3:=(HB-LB)/51;
B31:=HB-B3;
B32:=HB-2*B3;
B33:=HB-3*B3;
B34:=HB-4*B3;
B35:=HB-5*B3;
B36:=HB-6*B3;
B37:=HB-7*B3;
B38:=HB-8*B3;
B39:=HB-9*B3;
B310:=HB-10*B3;
B311:=HB-11*B3;
B312:=HB-12*B3;
B313:=HB-13*B3;
B314:=HB-14*B3;
B315:=HB-15*B3;
B316:=HB-16*B3;
B317:=HB-17*B3;
B318:=HB-18*B3;
B319:=HB-19*B3;
B320:=HB-20*B3;
B321:=HB-21*B3;
B322:=HB-22*B3;
B323:=HB-23*B3;
B324:=HB-24*B3;
B325:=HB-25*B3;
B326:=HB-26*B3;
B327:=HB-27*B3;
B328:=HB-28*B3;
B329:=HB-29*B3;
B330:=HB-30*B3;
B331:=HB-31*B3;
B332:=HB-32*B3;
B333:=HB-33*B3;
B334:=HB-34*B3;
B335:=HB-35*B3;
B336:=HB-36*B3;
B337:=HB-37*B3;
B338:=HB-38*B3;
B339:=HB-39*B3;
B340:=HB-40*B3;
B341:=HB-41*B3;
B342:=HB-42*B3;
B343:=HB-43*B3;
B344:=HB-44*B3;
B345:=HB-45*B3;
B346:=HB-46*B3;
B347:=HB-47*B3;
B348:=HB-48*B3;
B349:=HB-49*B3;
B350:=HB-50*B3;
B351:=HB-51*B3;
A1:=WINNER(HB)*100-WINNER(B31)*100;
A2:=WINNER(B31)*100-WINNER(B32)*100;
A3:=WINNER(B32)*100-WINNER(B33)*100;
A4:=WINNER(B33)*100-WINNER(B34)*100;
A5:=WINNER(B34)*100-WINNER(B35)*100;
A6:=WINNER(B35)*100-WINNER(B36)*100;
A7:=WINNER(B36)*100-WINNER(B37)*100;
A8:=WINNER(B37)*100-WINNER(B38)*100;
A9:=WINNER(B38)*100-WINNER(B39)*100;
A10:=WINNER(B39)*100-WINNER(B310)*100;
A11:=WINNER(B310)*100-WINNER(B311)*100;
A12:=WINNER(B311)*100-WINNER(B312)*100;
A13:=WINNER(B312)*100-WINNER(B313)*100;
A14:=WINNER(B313)*100-WINNER(B314)*100;
A15:=WINNER(B314)*100-WINNER(B315)*100;
A16:=WINNER(B315)*100-WINNER(B316)*100;
A17:=WINNER(B316)*100-WINNER(B317)*100;
A18:=WINNER(B317)*100-WINNER(B318)*100;
A19:=WINNER(B318)*100-WINNER(B319)*100;
A20:=WINNER(B319)*100-WINNER(B320)*100;
A21:=WINNER(B320)*100-WINNER(B321)*100;
A22:=WINNER(B321)*100-WINNER(B322)*100;
A23:=WINNER(B322)*100-WINNER(B323)*100;
A24:=WINNER(B323)*100-WINNER(B324)*100;
A25:=WINNER(B324)*100-WINNER(B325)*100;
A26:=WINNER(B325)*100-WINNER(B326)*100;
A27:=WINNER(B326)*100-WINNER(B327)*100;
A28:=WINNER(B327)*100-WINNER(B328)*100;
A29:=WINNER(B328)*100-WINNER(B329)*100;
A30:=WINNER(B329)*100-WINNER(B330)*100;
A31:=WINNER(B330)*100-WINNER(B331)*100;
A32:=WINNER(B331)*100-WINNER(B332)*100;
A33:=WINNER(B332)*100-WINNER(B333)*100;
A34:=WINNER(B333)*100-WINNER(B334)*100;
A35:=WINNER(B334)*100-WINNER(B335)*100;
A36:=WINNER(B335)*100-WINNER(B336)*100;
A37:=WINNER(B336)*100-WINNER(B337)*100;
A38:=WINNER(B337)*100-WINNER(B338)*100;
A39:=WINNER(B338)*100-WINNER(B339)*100;
A40:=WINNER(B339)*100-WINNER(B340)*100;
A41:=WINNER(B340)*100-WINNER(B341)*100;
A42:=WINNER(B341)*100-WINNER(B342)*100;
A43:=WINNER(B342)*100-WINNER(B343)*100;
A44:=WINNER(B343)*100-WINNER(B344)*100;
A45:=WINNER(B344)*100-WINNER(B345)*100;
A46:=WINNER(B345)*100-WINNER(B346)*100;
A47:=WINNER(B346)*100-WINNER(B347)*100;
A48:=WINNER(B347)*100-WINNER(B348)*100;
A49:=WINNER(B348)*100-WINNER(B349)*100;
A50:=WINNER(B349)*100-WINNER(B350)*100;
A51:=WINNER(B350)*100-WINNER(LB)*100;
T123:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(
A1,A2),A3),A4),A5),A6),A7),A8),A9),A10),A11),A12),A13),A14),A15),A16),A17),A18);
SMJ:IF(A1=T123,HB,IF(A2=T123,B31,IF(A3=T123,B32,IF(A4=T123,B33,IF(A5=T123,B34,
IF(A6=T123,B35,IF(A7=T123,B36,IF(A8=T123,B37,IF(A9=T123,B38,IF(A10=T123,B39,
IF(A11=T123,B310,IF(A12=T123,B311,IF(A13=T123,B312,IF(A14=T123,B313,IF(A15=T123,B314,
IF(A16=T123,B315,IF(A17=T123,B316,IF(A18=T123,B317,
DRAWNULL))))))))))))))))))COLORRED,LINETHICK2;
T25:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(
A19,A20),A21),A22),A23),A24),A25),A26),A27),A28),A29),A30),A31),A32),A33),A34),A35);
ZMJ:IF(A19=T25,B318,IF(A20=T25,B319,IF(A21=T25,B320,IF(A22=T25,B321,IF(A23=T25,B322,
IF(A24=T25,B323,IF(A25=T25,B324,IF(A26=T25,B325,IF(A27=T25,B326,IF(A28=T25,B327,
IF(A29=T25,B328,IF(A30=T25,B329,IF(A31=T25,B330,IF(A32=T25,B331,IF(A33=T25,B332,
IF(A34=T25,B333,IF(A35=T25,B334,IF(A36=T25,B335,
DRAWNULL))))))))))))))))))COLORRED,LINETHICK2;
T45:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(
A37,A38),A39),A40),A41),A42),A43),A44),A45),A46),A47),A48),A49),A50),A51);
XMJ:IF(A36=T45,B335,IF(A37=T45,B336,IF(A38=T45,B337,IF(A39=T45,B338,IF(A40=T45,B339,
IF(A41=T45,B340,IF(A42=T45,B341,IF(A43=T45,B342,IF(A44=T45,B343,IF(A45=T45,B344,
IF(A46=T45,B345,IF(A47=T45,B346,IF(A48=T45,B347,IF(A49=T45,B348,IF(A50=T45,B349,
IF(A51=T45,B351,
DRAWNULL))))))))))))))))COLORRED,LINETHICK2;
ZF:((H-REF(C,1))/(REF(C,1))+(REF(C,1)-L)/(REF(C,1)))*100,COLORMAGENTA,NODRAW;
CF:(C-REF(C,1))/(REF(C,1))*100,COLORYELLOW,NODRAW;
DCF:("999999$C"-REF("999999$C",1))/(REF("999999$C",1))*100,COLORLIRED,NODRAW;
DRAWICON(CURRBARSCOUNT<1000 AND PERIOD=5 AND((DCF<0.2 AND CF>9.75)),H*1.05,29);
DRAWKLINE(H,O,L,C);
STICKLINE(PERIOD=5 AND CF>1.0975 AND H=C AND O<>C,O,O+(H-O)/3,2.5,0),COLORMAGENTA;
STICKLINE(PERIOD=5 AND CF>1.0975 AND H=C AND O<>C,O+(H-O)/3,O+(H-O)/3*2,2.5,0)COLORYELLOW;
STICKLINE(PERIOD=5 AND CF>1.0975 AND H=C AND O<>C,O+(H-O)/3*2,C,2.5,0),COLORMAGENTA;

通达信筹码密集分布主图指标公式

 

相关文章