载入中...
在线检测未来函数
载入中...

通达信火中趋势主图指标公式

来源:Internet,编辑:股旁网,2019-10-08

BB13:=ATAN(EMA((C+L+H)/3,13)-REF(EMA((C+L+H)/3,13),1))*3.1416*10;
上:=EMA(C,3),COLORBLUE,LINETHICK1;
中:=EMA(C,5),COLORWHITE,LINETHICK1;
下:=EMA(中,5),COLOR00FF00,LINETHICK1;
QQ:=C<中;
MM:=上>REF(上,1) AND REF(上,1)<REF(上,2);
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
VAR03:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4)
AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4)
AND C<REF(C,1) AND C<REF(C,2);
VAR04:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3)
AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
VAR05:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3)
OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);
VAR06:=V5>REF(V5,1) AND REF(V5,1)<REF(V5,2);
VAR07:=LOW<HHV(V5,13) AND HIGH>HHV(V5,13) AND CLOSE>REF(C,1) AND CLOSE>OPEN;
VAR08:=VAR07 AND COUNT(VAR06,2);
VAR09:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
{趋势带}
R:=(3*C+L+O+H)/6;
K:=(20*R+19*REF(R,1)+18*REF(R,2)+17*REF(R,3)+16*REF(R,4)+15*REF(R,5)+14*REF(R,6)
+13*REF(R,7)+12*REF(R,8)+11*REF(R,9)+10*REF(R,10)+9*REF(R,11)+8*REF(R,12)
+7*REF(R,13)+6*REF(R,14)+5*REF(R,15)+4*REF(R,16)+3*REF(R,17)
+2*REF(R,18)+REF(R,20))/210,COLORRED,LINETHICK2;
D:=MA(K,6),COLORGREEN,LINETHICK2;
DRAWBAND(K,RGB(140,14,24),D,RGB(25,155,0));
{绿}
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3.0,0),COLOR00CC00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.7,0),COLOR003300;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.1,0),COLOR006600;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLOR009900;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.9,0),COLOR00CC00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.3,0),COLOR00FF00;
{红}
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.1,0),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3.0,0),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.7,0),COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.1,0),COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR0000BB;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.9,0),COLOR0000DD;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.3,0),COLOR0000FF;
{蓝色}
STICKLINE(VAR03,OPEN,(OPEN+CLOSE)/2,3.0,0),COLORFFFF33;
STICKLINE(VAR03,OPEN,(OPEN+CLOSE)/2,2.7,0),COLORFF3333;
STICKLINE(VAR03,OPEN,(OPEN+CLOSE)/2,2.1,0),COLORFF6633;
STICKLINE(VAR03,OPEN,(OPEN+CLOSE)/2,1.5,0),COLORFF9933;
STICKLINE(VAR03,OPEN,(OPEN+CLOSE)/2,0.9,0),COLORFFCC33;
STICKLINE(VAR03,OPEN,(OPEN+CLOSE)/2,0.3,0),COLORFFFF33;
{灰}
STICKLINE(VAR04 AND MM,OPEN,(OPEN+CLOSE)/2,3.0,0),COLOR00FFFF;
STICKLINE(VAR04 AND MM,OPEN,(OPEN+CLOSE)/2,2.7,0),COLOR0033FF;
STICKLINE(VAR04 AND MM,OPEN,(OPEN+CLOSE)/2,2.1,0),COLOR0066FF;
STICKLINE(VAR04 AND MM,OPEN,(OPEN+CLOSE)/2,1.5,0),COLOR0099FF;
STICKLINE(VAR04 AND MM,OPEN,(OPEN+CLOSE)/2,0.9,0),COLOR00CCFF;
STICKLINE(VAR04 AND MM,OPEN,(OPEN+CLOSE)/2,0.3,0),COLOR00FFFF;
{压力支撑}
A1:=C=HHV(C,6);
A2:=C=LLV(C,6);
A3:=BARSLAST(A1);
A4:=BARSLAST(A2);
A5:=IF(A3,REF(C,A3),REF(C,A3))*1.005;
A6:=IF(A4,REF(C,A4),REF(C,A4))*0.995;
压力:STICKLINE(A5=REF(A5,1),A5,A5,2,0),COLORLIBLUE;
支撑:STICKLINE(A6=REF(A6,1),A6,A6,2,0),COLORLIMAGENTA;
{个股信息}
SBL:=STRCAT(STRCAT(STRCAT(STRCAT(DYBLOCK,HYBLOCK),FGBLOCK),GNBLOCK),ZDBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0.01,0.005,0,SBL),COLORCYAN;
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市日期:=STRCAT(' 上市天数: ',CON2STR(FINANCE(42),0));
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));
DRAWTEXT_FIX(ISLASTBAR,0.01,0.055,0,股本市值),COLOR0090FF;
总涨跌比:=DYNAINFO(60)/(DYNAINFO(60)+DYNAINFO(61))*100,COLORCYAN,NODRAW;
DRAWTEXT_FIX(1,0.15,0.1,0,STRCAT('总涨跌比: ',CON2STR(总涨跌比,2))),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.08,0.1,0,STRCAT('主营同比: ',CON2STR(FINANCE(44),2))),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.1,0,STRCAT('利润同比: ',CON2STR(FINANCE(43),2))),COLORGREEN;
减仓:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
BUY(CROSS(MA(C,5),MA(C,7)),L);
SELLSHORT(CROSS(82,减仓),H);
XL1:=MA(L,2)*0.96;
XL2:=MA(L,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
XL4:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
XL5:=EMA(IF(L<=LLV(L,34),(EMA(XL4*13,13)+HHV(EMA(XL4*13,13),34)*2)/2,0),3)/618;
XL6:=(XL3 AND XL5>50) OR XL5>3;
XL7:=100-((90*(HHV(H,14)-C))/(HHV(H,14)-LLV(L,14)));
XL8:=100-MA(((100*(HHV(H,6)-C))/(HHV(H,6)-LLV(L,6))),34);
火中取粟:=XL6 AND CROSS(XL7,MA(XL8,6)),COLORRED,NODRAW;
DRAWICON(火中取粟,L,34);

通达信火中趋势主图指标公式

 

相关文章