载入中...
在线检测未来函数
载入中...

通达信MACD线和KDJ线及选股指标公式

来源:Internet,编辑:股旁网,2019-09-06

SHORT:=6;
LONG:=13;
MID:=5;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIF,MID);
MACD:(DIF-DEA)*2,COLORSTICK;
A:=BARSLAST(FILTERX(MACD=HHV(MACD,BARSLAST(MACD<0)),BARSLAST(MACD<0)));
B:=REF(MACD,A);
TT:=A+1;
ZTT:=REF(TT,TT)+TT;
KK:=REF(MACD,ZTT-1);
IF(CURRBARSCOUNT<CONST(ZTT+1),REFDATE(KK,DATE),DRAWNULL),COLORGREEN;

{
选股公式:

DIF:=EMA(CLOSE,6)-EMA(CLOSE,13);
DEA:=EMA(DIF,5);
AA:=CROSS(DIF,DEA);
RSV:=(CLOSE-LLV(LOW,39))/(HHV(HIGH,39)-LLV(LOW,39))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
BB:=CROSS(J,K);
XG:AA AND BB;
}

通达信MACD线和KDJ线及选股指标公式

 

相关文章