载入中...
在线检测未来函数
载入中...

通达信机构爆发指标公式

来源:Internet,编辑:股旁网,2019-08-23

爆发线:80,COLORRED;
即将爆发线: 65,COLORMAGENTA;
警戒线: 50,COLORCYAN;
低进线:=10,NODRAW;{第二版新加此线}
抄底线:7.5,COLORBROWN;{原为20,后10,现7.5可提前发现抄底时机}
趋势线:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),COLORWHITE,LINETHICK2;
LC:= REF(C,1);
F1:=ZIG(3,15);
上行:IF((F1> REF(F1,1)),105,5),COLORYELLOW,LINETHICK1;
IF(上行>50 AND (C>MA(C,10) OR C>REF(C,2)),趋势线,DRAWNULL),LINETHICK2,COLORRED;
IF(上行<50 AND (C>MA(C,10) OR C>REF(C,2)),趋势线,DRAWNULL),LINETHICK2,COLORRED;
IF(上行>50 AND (C<MA(C,10) OR C<REF(C,2)),趋势线,DRAWNULL),LINETHICK2,COLORGREEN;
IF(上行<50 AND (C<MA(C,10) OR C<REF(C,2)),趋势线,DRAWNULL),LINETHICK2,COLORGREEN;
DRAWTEXT(CROSS(趋势线,即将爆发线) AND 上行 > 50,趋势线,'★拉涨') ,COLORMAGENTA;{原爆发线}
DRAWTEXT(CROSS(趋势线,抄底线) AND 上行 < 50,趋势线,'★抄底') ,COLORWHITE;
DRAWTEXT(CROSS(趋势线,警戒线) AND 上行 < 50,趋势线,'★关注') ,COLORWHITE;
DRAWTEXT(CROSS(趋势线,警戒线) AND 上行 > 50,趋势线,'★加仓'),COLORCYAN;{原即将爆发线}
DRAWTEXT(CROSS(爆发线,趋势线),爆发线,'★换庄') ,COLORWHITE;
DRAWTEXT(((CROSS(上行,低进线)AND(趋势线 <= 10)) OR CROSS(趋势线,低进线)) AND 上行 > 50,趋势线,'★低进') ,COLORYELLOW;{原为(上行,抄底线)}
DRAWTEXT(CROSS(爆发线,上行),趋势线,'★高出') ,COLORRED;
抄底XG:CROSS(趋势线,抄底线) AND 上行 < 50,NODRAW,COLORWHITE;{曾上行 > 50}
低进XG:((CROSS(上行,低进线)AND(趋势线 <= 10)) OR CROSS(趋势线,低进线)) AND 上行 > 50,NODRAW,COLORYELLOW;{原(趋势线,抄底线),后(主力资金,低进线)}
加仓XG:CROSS(趋势线,警戒线) AND 上行 > 50,NODRAW,COLORCYAN;{原即将爆发线}
拉涨XG:CROSS(趋势线,即将爆发线) AND 上行 > 50,NODRAW,COLORMAGENTA;{原爆发线};
{增加基于MACD的钝化分析数字1~9}
YY:=((C-MA(C,6))/MA(C,6)*100+(C-MA(C,24))/MA(C,24)*100+(C-MA(C,32))/MA(C,32)*100)/3;
DRAWICON(YY>9 AND FILTER(YY<REF(YY,1),5),趋势线,15);{小人人}
{PP:=BARSLAST(CROSS(MA(C,5),MA(C,10)));
大趋势:=BARSLAST(CROSS(MA(C,10),MA(C,5))),COLOR00FFFF;
PP1:=IF(PP<大趋势,PP+1,0);
PP3:=MA(C,5)>MA(C,20) AND MA(C,10)>MA(C,20) AND MA(C,20)>REF(MA(C,20),1) AND MA(C,30)>REF(MA(C,30),1);
MC:=HHV(PP1,5)>=2 AND PP3 AND MA(C,5)>REF(MA(C,5),1) AND MA(C,5)>MA(C,10);}
{准备跑:MC*PP1,COLORFF0000,LINETHICK1;
STICKLINE(YY<-9 AND YY> REF(YY,1),抄底线,0,3,0),COLOR0000FF;
STICKLINE(YY>9 AND FILTER(YY<REF(YY,1),5),抄底线,0,3,0),COLOR80FF80;
STICKLINE(YY>20 AND FILTER(YY<REF(YY,1),5),抄底线,0,3,0),COLOR80FF80;
STICKLINE(HHV(YY>20,10) AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(C,20)+2*STD(C,20)),抄底线,0,3,0)COLORFF0033;}
A1:=C>REF(C,4);
NT:=BARSLASTCOUNT(A1);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;
DRAWTEXT(AY>0,趋势线*1.02,VAR2STR(AY,0)),COLORLIRED;
DRAWTEXT(NT=9,趋势线*1.02,'9'),COLORGREEN;
B1:=C<REF(C,4);
NT0:=BARSLASTCOUNT(B1);
TJ21:=NT0=9 ;
TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;
DRAWTEXT(AY1>0,趋势线*0.98,VAR2STR(AY1,0)),COLORGREEN;
DRAWTEXT(NT0=9,趋势线*0.98,'9'),COLORRED;

通达信机构爆发指标公式

 

相关文章