载入中...
在线检测未来函数
载入中...

通达信趋势黄金分割划线主图及选股指标公式

来源:Internet,编辑:股旁网,2019-08-16

N:=60;
JH:=HHVBARS(H,N);
YH:=BARSLAST(H=HHV(H,N));
QD:=CURRBARSCOUNT=CONST(YH)+1;
ZD:=CURRBARSCOUNT=CONST(JH)+1;
HH:=REF(H,YH);
DH:=REF(H,JH);
JD:=LLVBARS(L,JH);
LL:=CONST(REF(L,JD));
黄金线:IF(CURRBARSCOUNT<=CONST(JH)+1,(CONST(DH)-CONST(LL))*0.618+CONST(LL),DRAWNULL),DOTLINE,COLORMAGENTA;
IF(CURRBARSCOUNT<=CONST(JH)+1,CONST(DH),DRAWNULL),DOTLINE,COLORLIRED;
IF(CURRBARSCOUNT<=CONST(YH)+1,CONST(HH),DRAWNULL),DOTLINE,COLORYELLOW;
EXT1:DRAWLINE(QD,H,ZD,H,1),DOTLINE,COLORYELLOW;
STICKLINE(QD,H,L,0,0),COLORYELLOW;
STICKLINE(QD,C,O,2,0),COLORYELLOW;
STICKLINE(ZD,H,L,0,0),COLORLIRED;
STICKLINE(ZD,C,O,2,0),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=CONST(YH)+10,CONST(HH),VARCAT(VARCAT('远高价',VAR2STR(CONST(HH),2)),'元')),COLORYELLOW;
DRAWTEXT(ZD,H*1.02,VARCAT(VARCAT('近高价',VAR2STR(H,2)),'元')),COLORLIRED;
DRAWICON(CROSS(C,EXT1) AND CURRBARSCOUNT<CONST(JH)+1,L,1);
DRAWICON(CROSS(C,黄金线) AND CURRBARSCOUNT<CONST(JD)+1,L,25);

{
选股公式1:突破黄金线选股

N:=60;
JH:=HHVBARS(H,N);
YH:=BARSLAST(H=HHV(H,N));
QD:=CURRBARSCOUNT=CONST(YH)+1;
ZD:=CURRBARSCOUNT=CONST(JH)+1;
HH:=REF(H,YH);
DH:=REF(H,JH);
JD:=LLVBARS(L,JH) ;
LL:=CONST(REF(L,JD));
黄金线:=IF(CURRBARSCOUNT<=CONST(JH)+1,(CONST(DH)-CONST(LL))*0.618+CONST(LL),DRAWNULL);
CROSS(C,黄金线) AND CURRBARSCOUNT<CONST(JD)+1;
}

{
选股公式2:突破黄色趋势线选股

N:=60;
JH:=HHVBARS(H,N);
YH:=BARSLAST(H=HHV(H,N));
QD:=CURRBARSCOUNT=CONST(YH)+1;
ZD:=CURRBARSCOUNT=CONST(JH)+1;
HH:=REF(H,YH);
DH:=REF(H,JH);
JD:=LLVBARS(L,JH) ;
LL:=CONST(REF(L,JD));
EXT1:=DRAWLINE(QD,H,ZD,H,1);
CROSS(C,EXT1) AND CURRBARSCOUNT<=CONST(JH)+1;
}

通达信趋势黄金分割划线主图及选股指标公式

 

相关文章