载入中...
在线检测未来函数
载入中...

通达信资金博弈定乾坤指标公式

来源:Internet,编辑:股旁网,2019-08-13

指数趋势:EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),COLORCYAN,DOTLINE,LINETHICK1;
主力持仓:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),COLORRED,LINETHICK2;
CN1:=HHV(V,5);{5日最高量}
CN2:=O>C;
CN02:=C>O;
CN03:=C=O;
CN04:=((SUM(V,5)/CN1));
CN05:=IF(CN04>0.3,1,0);{大资金}
CN06:=IF(CN2 AND CN05,V,0);{大资金流出}
CN07:=IF(CN02 AND CN05,V,0);{大资金流入}
CN08:=IF(CN03 AND CN05,V,0);{不明流向大资金}
累积流入:SUM(CN07,9)/10000,COLORFF00FF,LINETHICK2;
累积流出:SUM(CN06,9)/10000,COLORGREEN,LINETHICK2;;
净流入:(累积流入-累积流出),COLORYELLOW,LINETHICK2;
净流入角度:=ATAN((净流入/REF(净流入,1)-1)*100)*57.3,NODRAW;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
TX98:90,COLOR408080,DOTLINE,LINETHICK1;
TX80:70,COLOR408080;
TX45:45,COLOR408080;
TX20:20,COLOR408080;
界:50,COLORRED;
80,COLORYELLOW;
0,COLORBLUE;
DRAWICON(CROSS(累积流入,累积流出) AND REF(累积流入,1)<REF(累积流出,1) AND MA(C,10)>REF(MA(C,10),1),66,34);
DRAWICON(CROSS(累积流出,累积流入) AND REF(累积流入,1)>REF(累积流出,1),66,35);
DRAWICON(CROSS(主力持仓,50) AND REF(主力持仓,1)<50,88,42);
近多:=EXIST(CROSS(主力持仓,50) AND REF(主力持仓,1)<50,3);
DRAWTEXT(CROSS(累积流出,累积流入) AND REF(累积流入,1)>REF(累积流出,1) AND 累积流出>净流入 AND 主力持仓-REF(主力持仓,1)<REF(主力持仓,1)<REF(主力持仓,2) AND 主力持仓<60 AND MA(C,10)<REF(MA(C,10),1) AND NOT(近多),90,'跑'),COLORGREEN;
DRAWICON(CROSS(净流入,累积流出) AND REF(净流入,1)<REF(累积流出,1),48,1);
长多:=累积流入>REF(累积流入,1) OR 主力持仓>REF(主力持仓,1);
DRAWTEXT(CROSS(累积流出,净流入) AND REF(累积流出,1)<REF(净流入,1) AND 主力持仓>50 AND MA(C,10)>REF(MA(C,10),1),24,'洗'),COLORGREEN;
诱空:=EXIST(CROSS(累积流入,累积流出) AND REF(累积流入,1)<REF(累积流出,1),5) AND CROSS(累积流出,净流入) AND REF(累积流出,1)<REF(净流入,1);
DRAWTEXT(诱空 AND 主力持仓>50 AND 主力持仓>=REF(主力持仓,1) ,77,'诱'),COLORRED;
DRAWTEXT(诱空 AND 主力持仓>50 AND 主力持仓>=REF(主力持仓,1),67,'空'),COLORRED;
DRAWTEXT(累积流出>累积流入 AND CROSS(主力持仓,累积流入) AND REF(主力持仓,1)<REF(累积流入,1) AND 净流入<50 AND 净流入<REF(净流入,1) AND 主力持仓<REF(主力持仓,1),67,'诱'),COLORGREEN;
DRAWTEXT(累积流出>累积流入 AND CROSS(主力持仓,累积流入) AND REF(主力持仓,1)<REF(累积流入,1) AND 净流入<50 AND 净流入<REF(净流入,1) AND 主力持仓<REF(主力持仓,1),57,'多'),COLORGREEN;
DRAWICON(主力持仓<50 AND REF(主力持仓,1)>50,88,43);
DRAWTEXT(主力持仓<80 AND REF(主力持仓,1)>80 AND 累积流入<累积流出 ,39,'空'),COLORGREEN;
DRAWTEXT(主力持仓<80 AND REF(主力持仓,1)>80 AND 累积流入<REF(累积流入,1) AND 净流入<REF(净流入,1) AND MA(C,5)<REF(MA(C,5),1),90,'卖'),COLORGREEN;
DRAWTEXT(主力持仓<80 AND REF(主力持仓,1)>80 AND 累积流入>累积流出,24,'洗'),COLORGREEN;
DRAWTEXT(累积流出>50 AND REF(累积流出,1)<50,34,'回'),COLORGREEN;
DRAWTEXT(累积流出>50 AND REF(累积流出,1)<50,24,'调'),COLORGREEN;
DRAWTEXT(CROSS(累积流出,累积流入) AND REF(累积流入,1)>REF(累积流出,1) AND CROSS(0,净流入) AND REF(净流入,1)>0 AND 主力持仓<REF(主力持仓,1),-8,'必'),COLORGREEN;
DRAWTEXT(CROSS(累积流出,累积流入) AND REF(累积流入,1)>REF(累积流出,1) AND CROSS(0,净流入) AND REF(净流入,1)>0 AND 主力持仓<REF(主力持仓,1) ,-18,'调'),COLORGREEN;
DRAWTEXT(CROSS(累积流入,累积流出) AND REF(累积流入,1)<REF(累积流出,1) AND CROSS(净流入,0) AND REF(净流入,1)<0 AND 主力持仓>REF(主力持仓,1) AND MA(C,5)>REF(MA(C,5),1),-8,'起'),COLORRED;
DRAWTEXT(CROSS(累积流入,累积流出) AND REF(累积流入,1)<REF(累积流出,1) AND CROSS(净流入,0) AND REF(净流入,1)<0 AND 主力持仓>REF(主力持仓,1) AND MA(C,5)>REF(MA(C,5),1),-18,'升'),COLORRED;
DRAWTEXT(累积流出>累积流入 AND REF(累积流出,1)<REF(累积流入,1) AND 主力持仓<60,77,'跑'),COLORGREEN;
DRAWTEXT(累积流出>主力持仓 AND REF(累积流出,1)<REF(主力持仓,1) AND 主力持仓<60 AND MA(C,10)<REF(MA(C,10),1),90,'跑'),COLORGREEN;
DRAWTEXT(CROSS(主力持仓,80) AND REF(主力持仓,1)<80,95,'牛'),COLORRED;
DRAWTEXT(CROSS(80,主力持仓) AND REF(主力持仓,1)>80,95,'减'),COLORGREEN;

通达信资金博弈定乾坤指标公式

 

相关文章