载入中...
在线检测未来函数
载入中...

通达信超级大主图指标公式

来源:Internet,编辑:股旁网,2019-07-23

N:=30;
N2:=7;
M:=4;
DRAWGBK(C>0, RGB(0,10,10),RGB(88,0,0),0,'11',0);
STICKLINE(C>=O,C,O,3,0),COLOR000045;
STICKLINE(C>=O,C,O,2.5,0),COLOR000065;
STICKLINE(C>=O,C,O,2,0),COLOR000085;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
STICKLINE(C>=O,H,L,0,0),COLOR0000F5;
STICKLINE(C<O,C,O,3,0),COLOR656500;
STICKLINE(C<O,C,O,2.5,0),COLOR757500;
STICKLINE(C<O,C,O,2,0),COLOR858500;
STICKLINE(C<O,C,O,1.5,0),COLOR959500;
STICKLINE(C<O,C,O,1,0),COLORA5A500;
STICKLINE(C<O,C,O,0.5,0),COLORB5B500;
STICKLINE(C<O,H,L,0,0),COLORC5C500;
EXP10:EMA(CLOSE,10)COLORWHITE,LINETHICK2;
EXP60:EMA(CLOSE,60)COLORYELLOW,LINETHICK2;
EXP金叉:=CROSS(EXP10,EXP60);
DRAWICON(EXP金叉,LOW-0.2,1);
DRAWTEXT(EXP金叉,LOW-0.7,'★EXP金叉买'),COLORLIMAGENTA;
跌破:=CROSS(EXP60,CLOSE);
DRAWICON(跌破,HIGH+0.1,2);
DRAWTEXT(跌破,HIGH+0.3,'←清仓离场'),COLORGREEN;
低位1:=(HHV(C,N)-REF(C,1))/HHV(C,N)>=0.50&&(HIGH/LOW)-1>0.07;
吊劲线:=MAX(OPEN,CLOSE)&&HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE));
日线:=MIN(OPEN,CLOSE)&&HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW);
EFCT1:=低位1&&吊劲线;
DRAWICON(EFCT1,LOW-0.2,1);
DRAWTEXT(EFCT1,LOW-0.5,'★吊射买入'),COLORYELLOW;
EFCT2:=低位1&&射日线;
DRAWICON(EFCT2,LOW-0.2,1);
DRAWTEXT(EFCT2,LOW-0.5,'★吊射买入'),COLORYELLOW;
低位2:=(HHV(C,N)-REF(C,1))/HHV(C,N)>=0.40&&(HIGH/LOW)-1>0.07;
地开大阳线:=OPEN/REF(CLOSE,1)<=1-M/100 && CLOSE/OPEN>=1+N2/100;
FEX:=低位2&&地开大阳线;
DRAWICON(FEX,LOW-0.5,1);
DRAWTEXT(FEX,LOW-0.7,'←分批建仓')COLORRED;
高1:=REF(HHV(H,150),3);
低1:=REF(LLV(L,150),3);
突破:REF(EMA(C,14),1)COLORMAGENTA,LINETHICK2;
A1X:=(EMA(C,14)-突破)/突破*100,NODRAW;
多方:IF(A1X>=0,REF(EMA(C,14),BARSLAST(CROSS(A1X,0))+1),DRAWNULL)COLORRED,LINETHICK2;
空方:IF(A1X<0,REF(EMA(C,14),BARSLAST(CROSS(0,A1X))+1),DRAWNULL)COLORGREEN,LINETHICK2;
STICKLINE(A1X>=0,多方,突破,0,-1)COLORRED;
STICKLINE(A1X<0,空方,突破,0,-1)COLORGREEN;
STICKLINE(CROSS(A1X,0),C,O,2,0)COLORYELLOW;
STICKLINE(CROSS(A1X,0),H,L,0,1)COLORYELLOW;
STICKLINE(CROSS(0,A1X),C,O,2,0)COLORGREEN;
STICKLINE(CROSS(0,A1X),H,L,0,1)COLORGREEN;
破位:IF(A1X<0,突破,DRAWNULL)COLORGREEN,LINETHICK2;
DP:=REF(EMA(INDEXC,14),1);
DPX:=(EMA(INDEXC,14)-DP)/DP*100;
DRAWICON(CROSS(0,A1X),HIGH+0.2,15);
DRAWTEXT(CROSS(0,A1X),HIGH+0.3,'『减磅')COLORGREEN;
DRAWICON(CROSS(EXP10,突破),LOW-0.2,1);
DRAWTEXT(CROSS(EXP10,突破),LOW-0.5,'★上穿买入')COLORMAGENTA;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;

通达信超级大主图指标公式

 

相关文章