载入中...
在线检测未来函数
载入中...

通达信擒牛伏妖主图指标公式

来源:Internet,编辑:股旁网,2019-06-17

所属地区:DRAWTEXT_FIX(1,0.00,0.05,0,'地区:'),COLORFFFF00;
DRAWTEXT_FIX(1,0.05,0.05,0,DYBLOCK),COLORFFFF00;
所属行业:DRAWTEXT_FIX(1,0,0.10,0,'行业:'),COLORFFFF00;
DRAWTEXT_FIX(1,0.05,0.10,0,HYBLOCK),COLORFFFF00;
所属概念:DRAWTEXT_FIX(1,0,0.15,0,'概念:'),COLORFFFF00;
DRAWTEXT_FIX(1,0.05,0.15,0,GNBLOCK),COLORFFFF00;
所属风格:DRAWTEXT_FIX(1,0,0.20,0,'风格:'),COLORFFFF00;
DRAWTEXT_FIX(1,0.05,0.20,0,FGBLOCK),COLORFFFF00;
上市日期:=CONST(DAYTODATE((DATETODAY(DATE)-FINANCE(42))))+19000000,NODRAW;
DRAWTEXT_FIX(1,0,0.25,0,'上市日期:'),COLORFFFF00;
DRAWNUMBER_FIX(1,0.05,0.25,0,上市日期),COLORFFFF00;
MA5:=MA(C,5);
MA20:=MA(C,20);
A51:= REF(MA5,1)*0.98;
A52:= REF(MA5,2)*0.98;
B52:= BARSLAST(REF(C,2)>=REF(MA5,2) AND REF(C,1)<REF(MA5,1))+2;
B51:= BARSLAST(REF(C,2)>=REF(MA5,2) AND REF(C,1)<REF(MA5,1))+1;
DZ:=IF((REF(C,2)>=REF(MA5,2)) AND (REF(C,1)<REF(MA5,1)),IF(REF(MA5,2)<REF(MA5,1),A51,A52),IF(BARSSINCE(REF(C,2)>=REF(MA5,2) AND REF(C,1)<REF(MA5,1))>0,IF(REF(MA5, B52)< REF(MA5, B51),REF(MA5,B51)*0.98, REF(MA5,B52)*0.98), REF(MA5,1)));
A201:= REF(MA20,1)*0.98;
A202:= REF(MA20,2)*0.98;
B202:= BARSLAST(REF(C,2)>=REF(MA20,2) AND REF(C,1)<REF(MA20,1))+2;
B201:= BARSLAST(REF(C,2)>=REF(MA20,2) AND REF(C,1)<REF(MA20,1))+1;
ZZ:=IF((REF(C,2)>=REF(MA20,2)) AND (REF(C,1)<REF(MA20,1)),IF(REF(MA20,2)<REF(MA20,1),A201,A202),IF(BARSSINCE(REF(C,2)>=REF(MA20,2) AND REF(C,1)<REF(MA20,1))>0,IF(REF(MA20, B202)< REF(MA20, B201),REF(MA20,B201)*0.98, REF(MA20,B202)*0.98), REF(MA20,1)));
短止:DZ,COLORWHITE,LINETHICK2;
紫线:ZZ,COLORMAGENTA;
绿线:LLV(REF(LOW,1),2)+(HHV(REF(HIGH,1),2)-LLV(REF(LOW,1),2))/2,COLORGREEN;
黄线:MA(CLOSE,25)+MA(CLOSE,25)*6/100,COLORYELLOW,LINETHICK2;
白轨:MA(CLOSE,25)+MA(CLOSE,25)*20/100,COLORWHITE;
影子线:MA(CLOSE,25)+MA(CLOSE,25)*13/100,COLORGRAY;
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;
AZZ:=LLV(REF(LOW,1),2)+(HHV(REF(HIGH,1),2)-LLV(REF(LOW,1),2))/2,COLORGREEN;
DRAWICON(REF(C,1)<REF(DZ,1) AND C>=DZ AND C>AZZ ,LOW*0.99,1);
DRAWICON(REF(C,1)<REF(AZZ,1) AND C>=AZZ,LOW*0.99,1);
AXX:=((((MA(C,10) > MA(C,25)) && CROSS(C,MA(C,5))) && (V > MA(V,10))) && (MA(C,10) > REF(MA(C,10),1)));
ASS:=C>=黄线 AND AXX ;
DRAWTEXT(ASS,L*0.99,'☆'), COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0,0.00,0,'说明: ☆为稳买'),COLORLIGREEN;
{涨跌停显示}
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
STICKLINE(涨停,O,C,1,0),COLORYELLOW;
XA:=(ATAN((MA(C,3)/REF(MA(C,3),1)-1)*100)*180/3.14115926)>60;
XB:=C/REF(C,2)>1.08 AND C=HHV(C,40);
妖股:XA AND XB AND BARSCOUNT(C)>19,NODRAW,COLORYELLOW;
DRAWICON(妖股,L,13);
DRAWTEXT(妖股,L*0.92,'妖股'),COLORYELLOW;
XC:=C=ZTPRICE(REF(C,1),0.1);
STICKLINE(XC,C,O,0.5,0)COLORYELLOW;
STICKLINE(XC,H,L,0.5,0),COLORYELLOW;
倍量:=V>REF(MA(V,5),1)*1.8 AND C>REF(C,1) AND BARSCOUNT(C)>15;
DRAWTEXT(倍量,L*0.97,'倍'),COLORMAGENTA,LINETHICK2;
DRAWTEXT(CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),
HIGH*1.02,'●警'),COLORGREEN;
{买入}
A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
DRAWTEXT(FILTER(买=1,5),LOW-0.05,'买进'),COLORYELLOW;
STICKLINE(买,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORMAGENTA;
N:=12;
DG:=1.2;
YLX:=0;
ZCX:=0;
A1:=REF(C,N)=HHV(C,2*N+1); B1:=FILTER(A1,N); C1:=BACKSET(B1,N+1); HD:=FILTER(C1,N);
A2:=REF(C,N)=LLV(C,2*N+1); B2:=FILTER(A2,N); C2:=BACKSET(B2,N+1); LD:=FILTER(C2,N);
UU:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);VV:=UU>REF(UU,1);
前高:REF(C,BARSLAST(VV)),COLORRED,LINETHICK2;
顶高:=REF(C,BARSLAST(VV))*DG,COLORGRAY,LINETHICK2;
PTZQ:=BARSLAST(VV);
PTZF:=(HHV(H,PTZQ)-LLV(L,PTZQ))/LLV(L,PTZQ)*100;
DRAWTEXT_FIX(1,0.5,0.04,0,STRCAT(STRCAT('平台周期 ',CON2STR(PTZQ,0)),' 天')),COLORRED;
DRAWTEXT_FIX(1,0.5,0.08,0,STRCAT(STRCAT('平台振幅 ',CON2STR(PTZF,0)),' %')),COLORYELLOW;

通达信擒牛伏妖主图指标公式

 

相关文章