载入中...
在线检测未来函数
载入中...

通达信股票买卖主图指标公式

来源:Internet,编辑:股旁网,2019-06-11

AA05:MA(C,30);
MA1:MA(CLOSE,30);
MA2:MA(CLOSE,40);
MA3:MA(CLOSE,50);
MA4:MA(CLOSE,60);
MA5:MA(CLOSE,70);
MA6:MA(CLOSE,80);
MA7:MA(CLOSE,90);
MA8:MA(CLOSE,100);
MA9:MA(CLOSE,110);
MA10:MA(CLOSE,120);
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),LINETHICK0;
AA10:MA(C,30);AA20:=MA(C,30);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:MA(C,30);
DRAWTEXT_FIX(C>0,0,0.05,0,'( 8 )'),COLORMAGENTA;
三拾日乖离率:=(C-AA30)/AA30*100,LINETHICK0;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05<REF(AA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10<REF(AA10,1),10);
DRAWTEXT(加仓 ,LOW*0.98,'加仓'),COLORRED;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10>REF(AA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10);
DRAWTEXT(减仓,HIGH*1.02,'减仓'),COLORCYAN;
DRAWTEXT(买入,LOW*0.98,'买入'),COLORYELLOW;
DRAWTEXT(清仓 ,HIGH*1.02,'清仓'),COLORGREEN;
DRAWTEXT(强势狙击,LOW*0.98,'狙击'),COLORYELLOW;
AAA:=CONST(HHV(H*0.5,90));
A74:=MA(CLOSE,20);
A75:=(CLOSE > MA(CLOSE,5));
A76:=(MA(CLOSE,5) > MA(CLOSE,10));
A77:=(CLOSE > MA(CLOSE,10));
A78:=(MA(CLOSE,5) > MA(CLOSE,20));
A79:=(CLOSE > MA(CLOSE,20));
A710:=REF(A74,1);
A711:=(A74 > A710);
AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10)))+ IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
T1:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T2:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T3:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)),1,0));
T4:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)),1,0));
T5:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T6:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T7:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T8:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T9:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T10:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T11:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T12:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T13:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T14:=CONST(IF( C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T15:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T16:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T17:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
T18:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
T19:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 < V2)),1,0));
T20:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 >= V2)),1,0));
T21:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 < V2)),1,0));
T22:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)),1,0));
T23:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)),1,0));
T24:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)),1,0));
T25:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)),1,0));
{涨停柱红涨停兰跌停}
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLOR0000FF;
STICKLINE(涨停,H,L,0,0),COLOR0000FF;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
DRAWTEXT(T1=1 AND CURRBARSCOUNT=70,CLOSE,'量能理想,明显走强,中线参与,仓位在2/3左右。'),COLORFF00FF ;
DRAWTEXT(T2=1 AND CURRBARSCOUNT=70,CLOSE,'走势趋强,还显不足,短线进场,仓位在1/2左右。'),COLORFFFFFF ;
DRAWTEXT(T3=1 AND CURRBARSCOUNT=70,CLOSE,'量价良好,没有明显走强,短线进场,仓位1/2左右。'),COLORFFFFFF ;
DRAWTEXT(T4=1 AND CURRBARSCOUNT=70,CLOSE,'形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右。'),COLORFFFFFF ;
DRAWTEXT(T5=1 AND CURRBARSCOUNT=70,CLOSE,'形态变坏,重仓者减持大半,清仓者观望。'),COLORFFFFFF ;
DRAWTEXT(T6=1 AND CURRBARSCOUNT=70,CLOSE,'随大盘一起下跌,明显缩量走势,考虑到风险,减持或清仓。'),COLORFFFFFF ;
DRAWTEXT(T7=1 AND CURRBARSCOUNT=70,CLOSE,'该股放量下跌,走势明显偏弱,离场观望。'),COLORFFFFFF ;
DRAWTEXT(T8=1 AND CURRBARSCOUNT=70,CLOSE,'该股缩量下跌,走势偏弱,离场观望。'),COLORFF00FF ;
DRAWTEXT(T9=1 AND CURRBARSCOUNT=70,CLOSE,'该股形态良好,强势明显,量能充足,可以继续持有。'),COLORFFFFFF ;
DRAWTEXT(T10=1 AND CURRBARSCOUNT=70,CLOSE,'上行趋势不变,强势依然,量能开始转弱,注意风险。'),COLORFFFFFF ;
DRAWTEXT(T11=1 AND CURRBARSCOUNT=70,CLOSE,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。'),COLORFFFFFF ;
DRAWTEXT(T12=1 AND CURRBARSCOUNT=70,CLOSE,'该股走势趋弱,量能不足,减持大部分筹码。'),COLORFFFFFF ;
DRAWTEXT(T13=1 AND CURRBARSCOUNT=70,CLOSE,'该股形态不佳,注意成交量的变化,目前不适合参与。'),COLORFFFFFF ;
DRAWTEXT(T14=1 AND CURRBARSCOUNT=70,CLOSE,'趋势不明,股价偏弱,注意量能变化,目前不宜参与。'),COLORFFFFFF ;
DRAWTEXT(T15=1 AND CURRBARSCOUNT=70,CLOSE,'有走强迹象,但量能不足,趋势不明,不适合操作。'),COLORFFFFFF ;
DRAWTEXT(T16=1 AND CURRBARSCOUNT=70,CLOSE,'该股走势太弱,没有参与价值。'),COLORFF00FF ;
DRAWTEXT(T17=1 AND CURRBARSCOUNT=70,CLOSE,'大盘理想,有明显走强迹象,中线参与,仓位在2/3左右。'),COLORFFFFFF ;
DRAWTEXT(T18=1 AND CURRBARSCOUNT=70,CLOSE,'如前期经过一轮下跌,最佳买点,前期有过一段涨幅需谨慎。'),COLORFFFFFF ;
DRAWTEXT(T19=1 AND CURRBARSCOUNT=120,CLOSE,'考虑短线进场,仓位在1/2左右,一旦量能放大,加仓买入。'),COLORFFFFFF ;
DRAWTEXT(T20=1 AND CURRBARSCOUNT=70,CLOSE,'大盘形态走坏,重仓者可以减去大部分仓位。'),COLORFF0000 ;
DRAWTEXT(T21=1 AND CURRBARSCOUNT=70,CLOSE,'大盘缩量调整,注意风险,短线清仓观望。'),COLORFF0000 ;
DRAWTEXT(T22=1 AND CURRBARSCOUNT=70,CLOSE,'大盘走势良好,量能理想,可以继续持有强势股。'),COLORFF0000 ;
DRAWTEXT(T23=1 AND CURRBARSCOUNT=70,CLOSE,'大盘形态良好,但量能稍显不足,随时准备减仓。'),COLORFF0000 ;
DRAWTEXT(T24=1 AND CURRBARSCOUNT=70,CLOSE,'大盘趋势不明,注意成交量变化,目前不适宜进场。'),COLORFF0000 ;
DRAWTEXT(T25=1 AND CURRBARSCOUNT=70,CLOSE,'大盘趋势向下,量能萎缩,不适合进场。'),COLORFF0000 ;
压力:MA(REF(HHV(C,30),1),2),COLORBLUE,DOTLINE,LINETHICK2;
DRAWTEXT_FIX(ISLASTBAR,0,0,0,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.08,0,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.16,0,0,GNBLOCK),COLORYELLOW;
BB:REF(V,BARSLAST(TIME>=92500 AND TIME<=93000));
DRAWTEXT_FIX(ISLASTBAR,0.24,0,0,BB),COLORYELLOW;

通达信股票买卖主图指标公式

 

相关文章