载入中...
在线检测未来函数
载入中...

通达信阴阳脸主图指标公式

来源:Internet,编辑:股旁网,2019-05-06

X_1:=FROMOPEN<240;
X_2:=X_1<=0;
X_3:=1;
X_4:=1281210;
X_5:=IF(DATE>X_4,X_2,X_3);
X_6:=IF(DATE>X_4,0,1);
X_7:=IF(DATE>X_4,1,0);
CLOSE;
DRAWGBK(OPEN>CLOSE,RGB(1,88,92),RGB(1,22,28),0,7,0);
X_8:=1 AND X_6;
X_9:=(XMA(XMA(HIGH,25),25)-XMA(XMA(LOW,25),25))*1+XMA(XMA(HIGH,25),25);
X_10:=XMA(XMA(LOW,25),25)-(XMA(XMA(HIGH,25),25)-XMA(XMA(LOW,25),25))*1;
X_11:=X_8*(XMA(XMA(HIGH,60),60)-XMA(XMA(LOW,60),60))*2.2+XMA(XMA(HIGH,60),60);
X_12:=X_8*XMA(XMA(LOW,60),60)-(XMA(XMA(HIGH,60),60)-XMA(XMA(LOW,60),60))*2.8;
X_13:=X_8*(X_9+X_11)/2;
X_14:=X_8*(X_10+X_12)/2;
DRAWBAND(X_13,RGB(0,100,0),X_11,RGB(0,100,0));
DRAWBAND(X_14,RGB(150,0,150),X_12,RGB(150,0,150));
收盘价:CLOSE,NODRAW,COLORWHITE;
涨跌幅:(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100,NODRAW,COLORYELLOW;
最新价:IF(CLOSE,CONST(CLOSE),DRAWNULL),DOTLINE,COLORRED;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
NOTEXT_DYN:DYNAINFO(7),DOTLINE,COLORYELLOW;
DRAWNUMBER(ISLASTBAR=1,DYNAINFO(7),DYNAINFO(7)),COLORWHITE,LINETHICK9;
X_15:=(HIGH+LOW)/2;
X_16:=X_15;
X_17:=XMA(X_15,3);
X_18:=XMA(X_15,5);
X_19:=XMA(X_15,10);
X_20:=XMA(X_15,15);
X_21:=XMA(X_15,20);
X_22:=XMA(X_15,25);
X_23:=XMA(X_15,30);
X_24:=XMA(X_15,35);
X_25:=XMA(X_15,40);
X_26:=XMA(X_15,45);
X_27:=XMA(X_15,50);
X_28:=XMA(X_15,55);
X_29:=XMA(X_15,60);
X_30:=(X_17+X_18+X_19+X_20+X_21+X_22+X_23+X_24+X_25+X_26+X_27+X_28+X_29)/13;
X_31:=(X_16+X_17+X_18)/3;
X_32:=PLOYLINE(2>1,X_30);
X_33:=X_16>X_17 AND X_16>X_18 AND X_16>X_19 AND X_16>X_20 AND X_16>X_21 AND X_16>X_22 AND X_16>X_23 AND X_16>X_24 AND X_16>X_25 AND X_16>X_26 AND X_16>X_27 AND X_16>X_28 AND X_16>X_29 AND X_17>X_18 AND X_17>X_19 AND X_17>X_20 AND X_17>X_21 AND X_17>X_22 AND X_17>X_23;
X_34:=X_17>X_24 AND X_17>X_25 AND X_17>X_26 AND X_17>X_27 AND X_17>X_28 AND X_17>X_29 AND X_18>X_19 AND X_18>X_20 AND X_18>X_21 AND X_18>X_22 AND X_18>X_23 AND X_18>X_24 AND X_18>X_25 AND X_18>X_26 AND X_18>X_27 AND X_18>X_28 AND X_18>X_29 AND X_19>X_20 AND X_19>X_21 AND X_19>X_22 AND X_19>X_23 AND X_19>X_24 AND X_19>X_25 AND X_19>X_26 AND X_19>X_27 AND X_19>X_28 AND X_19>X_29;
X_35:=X_20>X_21 AND X_20>X_22 AND X_20>X_23 AND X_20>X_24 AND X_20>X_25 AND X_20>X_26 AND X_20>X_27 AND X_20>X_28 AND X_20>X_29 AND X_21>X_22 AND X_21>X_23 AND X_21>X_24 AND X_21>X_25 AND X_21>X_26 AND X_21>X_27 AND X_21>X_28 AND X_21>X_29 AND X_22>X_23 AND X_22>X_24 AND X_22>X_25 AND X_22>X_26 AND X_22>X_27 AND X_22>X_28 AND X_22>X_29 AND X_23>X_24 AND X_23>X_25;
X_36:=X_23>X_26 AND X_23>X_27 AND X_23>X_28 AND X_23>X_29 AND X_24>X_25 AND X_24>X_26 AND X_24>X_27 AND X_24>X_28 AND X_24>X_29 AND X_25>X_26 AND X_25>X_27 AND X_25>X_28 AND X_25>X_29 AND X_26>X_27 AND X_26>X_28 AND X_26>X_29 AND X_27>X_28 AND X_27>X_29 AND X_28>X_29;
X_37:=X_33 AND X_34 AND X_35 AND X_36;
X_38:=X_16<X_17 AND X_16<X_18 AND X_16<X_19 AND X_16<X_20 AND X_16<X_21 AND X_16<X_22 AND X_16<X_23 AND X_16<X_24 AND X_16<X_25 AND X_16<X_26 AND X_16<X_27 AND X_16<X_28 AND X_16<X_29 AND X_17<X_18 AND X_17<X_19 AND X_17<X_20 AND X_17<X_21 AND X_17<X_22 AND X_17<X_23;
X_39:=X_17<X_24 AND X_17<X_25 AND X_17<X_26 AND X_17<X_27 AND X_17<X_28 AND X_17<X_29 AND X_18<X_19 AND X_18<X_20 AND X_18<X_21 AND X_18<X_22 AND X_18<X_23 AND X_18<X_24 AND X_18<X_25 AND X_18<X_26 AND X_18<X_27 AND X_18<X_28 AND X_18<X_29 AND X_19<X_20 AND X_19<X_21;
X_40:=X_19<X_22 AND X_19<X_23 AND X_19<X_24 AND X_19<X_25 AND X_19<X_26 AND X_19<X_27 AND X_19<X_28 AND X_19<X_29 AND X_20<X_21 AND X_20<X_22 AND X_20<X_23 AND X_20<X_24 AND X_20<X_25 AND X_20<X_26 AND X_20<X_27 AND X_20<X_28 AND X_20<X_29 AND X_21<X_22;
X_41:=X_21<X_23 AND X_21<X_24 AND X_21<X_25 AND X_21<X_26 AND X_21<X_27 AND X_21<X_28 AND X_21<X_29 AND X_22<X_23 AND X_22<X_24 AND X_22<X_25 AND X_22<X_26 AND X_22<X_27 AND X_22<X_28 AND X_22<X_29 AND X_23<X_24 AND X_23<X_25 AND X_23<X_26 AND X_23<X_27;
X_42:=X_23<X_28 AND X_23<X_29 AND X_24<X_25 AND X_24<X_26 AND X_24<X_27 AND X_24<X_28 AND X_24<X_29 AND X_25<X_26 AND X_25<X_27 AND X_25<X_28 AND X_25<X_29 AND X_26<X_27 AND X_26<X_28 AND X_26<X_29 AND X_27<X_28 AND X_27<X_29 AND X_28<X_29;
X_43:=X_38 AND X_39 AND X_40 AND X_41 AND X_42;
X_44:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
X_45:=SMA(X_14,3,1);
X_46:=SMA(X_45,3,1);
X_47:=SMA(X_46,3,1);
X_48:=X_46;
X_49:=X_47;
X_50:=X_46<20;
X_51:=X_46>80;
X_52:=X_50 OR X_51;
STICKLINE(X_37 AND CLOSE>=OPEN AND CLOSE<X_13*1.1 AND X_52,HIGH,LOW,0.6,0),COLORRED;
STICKLINE(X_37 AND CLOSE>=OPEN AND CLOSE<X_13*1.1 AND X_52,CLOSE,OPEN,3,0),COLORRED;
STICKLINE(X_43 AND CLOSE>=OPEN AND CLOSE<X_13*1.1 AND X_52,HIGH,LOW,0.6,0),COLORRED;
STICKLINE(X_43 AND CLOSE>=OPEN AND CLOSE<X_13*1.1 AND X_52,CLOSE,OPEN,3,0),COLORRED;
STICKLINE(X_37 AND CLOSE<OPEN AND CLOSE<X_14*1.1 AND X_52,HIGH,LOW,0.6,0),COLORGREEN;
STICKLINE(X_37 AND CLOSE<OPEN AND CLOSE<X_14*1.1 AND X_52,CLOSE,OPEN,3,0),COLORGREEN;
STICKLINE(X_43 AND CLOSE<OPEN AND CLOSE<X_14*1.1 AND X_52,HIGH,LOW,0.6,0),COLORGREEN;
STICKLINE(X_43 AND CLOSE<OPEN AND CLOSE<X_14*1.1 AND X_52,CLOSE,OPEN,3,0),COLORGREEN;
X_53:=(HIGH+XMA(HIGH,3)+XMA(HIGH,5)+XMA(HIGH,10)+XMA(HIGH,15)+XMA(HIGH,20)+XMA(HIGH,25)+XMA(HIGH,30)+XMA(HIGH,35)+XMA(HIGH,40)+XMA(HIGH,45)+XMA(HIGH,50)+XMA(HIGH,55)+XMA(HIGH,60))/14;
X_54:=(LOW+XMA(LOW,3)+XMA(LOW,5)+XMA(LOW,10)+XMA(LOW,15)+XMA(LOW,20)+XMA(LOW,25)+XMA(LOW,30)+XMA(LOW,35)+XMA(LOW,40)+XMA(LOW,45)+XMA(LOW,50)+XMA(LOW,55)+XMA(LOW,60))/14;
X_55:=X_20>X_21 AND X_20>X_22 AND X_20>X_23 AND X_20>X_24 AND X_20>X_25 AND X_20>X_26 AND X_20>X_27 AND X_20>X_28 AND X_20>X_29 AND X_21>X_22 AND X_21>X_23 AND X_21>X_24 AND X_21>X_25 AND X_21>X_26 AND X_21>X_27 AND X_21>X_28 AND X_21>X_29 AND X_22>X_23 AND X_22>X_24 AND X_22>X_25 AND X_22>X_26 AND X_22>X_27 AND X_22>X_28 AND X_22>X_29 AND X_23>X_24 AND X_23>X_25 AND X_23>X_26 AND X_23>X_27 AND X_23>X_28 AND X_23>X_29 AND X_24>X_25 AND X_24>X_26 AND X_24>X_27 AND X_24>X_28 AND X_24>X_29 AND X_25>X_26 AND X_25>X_27 AND X_25>X_28 AND X_25>X_29 AND X_26>X_27 AND X_26>X_28 AND X_26>X_29 AND X_27>X_28 AND X_27>X_29 AND X_28>X_29;
X_56:=X_20<X_21 AND X_20<X_22 AND X_20<X_23 AND X_20<X_24 AND X_20<X_25 AND X_20<X_26 AND X_20<X_27 AND X_20<X_28 AND X_20<X_29 AND X_21<X_22 AND X_21<X_23 AND X_21<X_24 AND X_21<X_25 AND X_21<X_26 AND X_21<X_27 AND X_21<X_28 AND X_21<X_29 AND X_22<X_23 AND X_22<X_24 AND X_22<X_25 AND X_22<X_26 AND X_22<X_27 AND X_22<X_28 AND X_22<X_29 AND X_23<X_24 AND X_23<X_25 AND X_23<X_26 AND X_23<X_27 AND X_23<X_28 AND X_23<X_29 AND X_24<X_25 AND X_24<X_26 AND X_24<X_27 AND X_24<X_28 AND X_24<X_29 AND X_25<X_26 AND X_25<X_27 AND X_25<X_28 AND X_25<X_29 AND X_26<X_27 AND X_26<X_28 AND X_26<X_29 AND X_27<X_28 AND X_27<X_29 AND X_28<X_29;
X_57:=XMA(X_53/X_54*X_30+(X_53/X_54*X_30-X_30),10);
X_58:=XMA(X_54/X_53*X_30-(X_30-X_54/X_53*X_30),10);
X_59:=IF(REF(X_30,1)<X_30 AND NOT(X_55),X_57,DRAWNULL);
X_60:=IF(REF(X_30,1)>X_30 AND NOT(X_56),X_58,DRAWNULL);
X_61:=XMA(X_53/X_54*X_30+(X_53/X_54*X_30-X_30)/2,10);
X_62:=XMA(X_54/X_53*X_30-0.5*(X_30-X_54/X_53*X_30),10);
X_63:=IF(REF(X_30,1)>X_30,X_61,DRAWNULL);
X_64:=IF(REF(X_30,1)<X_30,X_62,DRAWNULL);
X_65:=X_53/X_54*X_30+(X_53/X_54*X_30-X_30)*1.5;
X_66:=X_54/X_53*X_30-1.5*(X_30-X_54/X_53*X_30);
X_67:=PLOYLINE(2>1,X_65);
X_68:=PLOYLINE(2>1,X_66);
X_69:=IF(REF(X_30,1)<X_30 AND X_55,X_65,DRAWNULL);
X_70:=IF(REF(X_30,1)>X_30 AND X_56,X_66,DRAWNULL);
X_71:=IF(X_37,X_65,DRAWNULL);
X_72:=IF(X_43,X_66,DRAWNULL);
交时1:=FROMOPEN<240;
交时2:=交时1<=0;
交时3:=1;
DAYN1:=1281210;
定时1:=IF(DATE>DAYN1,交时2,交时3);
定时2:=IF(DATE>DAYN1,0,1);
定时3:=IF(DATE>DAYN1,1,0);
所属板块:=STRCAT('【所属板块】',STRCAT(STRCAT(STRCAT('【行业】',HYBLOCK),STRCAT('【地域】',DYBLOCK)),STRCAT('【概念】',GNBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0,0,0,所属板块),COLORYELLOW;
DRAWTEXT_FIX(1 AND 定时3,0.30,0.75,0,'如果看到这些文字,说明【印钞机3代】指标公式试用已到期,如果认为对你炒股,炒原油,炒外汇黄金'),COLORYELLOW;
DRAWTEXT_FIX(1 AND 定时3,0.30,0.81,0,'等期货有用,请加设计编写QQ:2679426676,或者到股票公式指标群重新下载,(**号:303313976)'),COLORYELLOW;
DRAWTEXT_FIX(1 AND 定时3,0.30,0.87,0,'【印钞机3代】必须与副图的【印钞机副图3】MACD背离指标同步使用,则神效更准,高胜算率。'),COLORYELLOW;
鬼头鬼脸鬼脚:IF(定时3,0,DRAWNULL),COLORBLUE;
{以下为第二组:鬼吹灯阴阳鬼脸-鬼头鬼脸鬼脚-鬼吹灯自编}
{鬼脸 选股 预警 确保向下笔成立后的阳鬼脸}
V00:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);
V01:= HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);
V02:= HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);
V03:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);
V04:= REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW
AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);
V1:= COUNT(V00,6)>=3 AND COUNT(V01 OR V02,5)=0 AND LLVBARS(LOW,6) = 1 AND HHVBARS(HIGH,6) >= 5 AND V03;
V2:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 2 AND HHVBARS(HIGH,7) >= 6 AND V04;
V3:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 1 AND HHVBARS(HIGH,7) >= 6 AND V03;
V4:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 2 AND HHVBARS(HIGH,8) >= 7 AND V04;
V5:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 1 AND HHVBARS(HIGH,8) >= 7 AND V03;
V6:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 2 AND HHVBARS(HIGH,9) >= 8 AND V04;
V7:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 1 AND HHVBARS(HIGH,9) >= 8 AND V03;
V8:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 2 AND HHVBARS(HIGH,10) >= 9 AND V04;
V9:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 1 AND HHVBARS(HIGH,10) >= 9 AND V03;
V10:= COUNT(V00,11)>=3 AND COUNT(V01 OR V02,10)<=5 AND LLVBARS(LOW,11) = 2 AND HHVBARS(HIGH,11) >= 10 AND V04;
XG:= V1 OR V2 OR V3 OR V4 OR V5 OR V6 OR V7 OR V8 OR V9 OR V10;
DRAWTEXT(FILTER(XG=1,5),LOW,'阳鬼脸'),COLORYELLOW;
{鬼脸 选股 预警 确保向上笔成立后的阴鬼脸}
HV00:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);
HV01:= HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);
HV02:= HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);
HV03:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);
HV04:= REF(HIGH,2) > HIGH AND REF(LOW,2) > LOW AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);
HV1:= COUNT(HV00,6)>=3 AND COUNT(HV01 OR HV02,5)=0 AND HHVBARS(HIGH,6) = 1 AND LLVBARS(LOW,6) >= 5 AND HV03;
HV2:= COUNT(HV00,7)>=3 AND COUNT(HV01 OR HV02,6)=1 AND HHVBARS(HIGH,7) = 2 AND LLVBARS(LOW,7) >= 6 AND HV04;
HV3:= COUNT(HV00,7)>=3 AND COUNT(HV01 OR HV02,6)=1 AND HHVBARS(HIGH,7) = 1 AND LLVBARS(LOW,7) >= 6 AND HV03;
HV4:= COUNT(HV00,8)>=3 AND COUNT(HV01 OR HV02,7)<=2 AND HHVBARS(HIGH,8) = 2 AND LLVBARS(LOW,8) >= 7 AND HV04;
HV5:= COUNT(HV00,8)>=3 AND COUNT(HV01 OR HV02,7)<=2 AND HHVBARS(HIGH,8) = 1 AND LLVBARS(LOW,8) >= 7 AND HV03;
HV6:= COUNT(HV00,9)>=3 AND COUNT(HV01 OR HV02,8)<=3 AND HHVBARS(HIGH,9) = 2 AND LLVBARS(LOW,9) >= 8 AND HV04;
HV7:= COUNT(HV00,9)>=3 AND COUNT(HV01 OR HV02,8)<=3 AND HHVBARS(HIGH,9) = 1 AND LLVBARS(LOW,9) >= 8 AND HV03;
HV8:= COUNT(HV00,10)>=3 AND COUNT(HV01 OR HV02,9)<=4 AND HHVBARS(HIGH,10) = 2 AND LLVBARS(LOW,10) >= 9 AND HV04;
HV9:= COUNT(HV00,10)>=3 AND COUNT(HV01 OR HV02,9)<=4 AND HHVBARS(HIGH,10) = 1 AND LLVBARS(LOW,10) >= 9 AND HV03;
HV10:= COUNT(HV00,11)>=3 AND COUNT(HV01 OR HV02,10)<=5 AND HHVBARS(HIGH,11) = 2 AND LLVBARS(LOW,11) >= 10 AND HV04;
HXG:=HV1 OR HV2 OR HV3 OR HV4 OR HV5 OR HV6 OR HV7 OR HV8 OR HV9 OR HV10;
DRAWTEXT(FILTER(HXG=1,3),HHV(HIGH,3),'阴鬼脸'),COLORGREEN;

通达信阴阳脸主图指标公式

 

通达信阴阳脸主图指标公式的选股公式如下:

相关文章