载入中...
在线检测未来函数
载入中...

通达信超级飓风眼主图指标公式

来源:Internet,编辑:股旁网,2019-02-08

NN:=21;
MM:=8;
P:=4;
K:=12;
K2:=1;
K3:=8;
{卖出}
VAR55:=EMA(EMA(EMA(CLOSE,8),13),62);
VAR56:=((REF(HIGH,1) + REF(LOW,1)) / 2);
VAR57:=(MA(CLOSE,20) + (2 * STD(CLOSE,20)));
VAR58:=((SMA(MAX((CLOSE - REF(CLOSE,1)),0),7,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),7,1)) * 100);
卖出1:=FILTER(CROSS(79,VAR58),4);
MA21:=REF(CLOSE,1);
ZX:=((SMA(MAX((CLOSE - MA21),0),6,1) / SMA(ABS((CLOSE - MA21)),6,1)) * 100);
卖出2:=CROSS(84,ZX);
卖出3:=CROSS(90,RSI);
卖出:=卖出1 OR 卖出2 OR 卖出3;
DRAWICON(卖出,(LOW * 1.1),12);
A:=EMA((EMA(C,29)+EMA(C,31)+EMA(C,33))/3,3);
A1:=EMA((EMA(C,1)+EMA(C,3)+EMA(C,5))/3,3),COLOR1010FF;
A3:=IF(K2!=2,EMA((EMA(C,5)+EMA(C,6)+EMA( C,7))/3,3),DRAWNULL),COLORCYAN,LINETHICK3;{COLOR1030FF;}
A4:=IF(K2!=2, EMA((EMA(C,7)+EMA(C,9)+EMA( C,11))/3,3),DRAWNULL),COLOR1040FF;
A5:=IF(K2!=2, EMA((EMA(C,9)+EMA(C,11)+EMA( C,13))/3,3),DRAWNULL)COLOR1050FF;
A6:=IF(K2!=2, EMA((EMA(C,11)+EMA(C,13)+EMA( C,15))/3,3),DRAWNULL)COLOR1060FF;
A7:=IF(K2!=2, EMA((EMA(C,13)+EMA(C,15)+EMA( C,17))/3,3),DRAWNULL)COLOR1070FF;
A8:=IF(K2!=2, EMA((EMA(C,15)+EMA(C,17)+EMA( C,19))/3,3),DRAWNULL)COLOR1080FF;
A9:=IF(K2!=2, EMA((EMA(C,17)+EMA(C,19)+EMA( C,21))/3,3),DRAWNULL),COLORLIMAGENTA;{COLOR1080EF;}
A10D:=IF(K2!=2, EMA((EMA(C,19)+EMA(C,21)+EMA( C,23))/3,3),DRAWNULL),COLORLIMAGENTA;{COLOR10C0FF;}
A11D:=IF(K2!=2, EMA((EMA(C,21)+EMA(C,23)+EMA( C,25))/3,3),DRAWNULL),COLORWHITE,LINETHICK2;
A15D:IF(K2!=2, A-(A1-A*0.977),DRAWNULL),COLORBLUE,LINETHICK3;{COLORFF0000;原997}
A24D:=IF(K2!=2, A-(A10D-A),DRAWNULL)COLORF6D030;
A25D:=IF(K2!=2, A-(A11D-A*0.987),DRAWNULL)COLORF5F030;{原997}
AK2:=IF(K2=2,EMA((EMA(C,5)+EMA(C,7)+EMA( C,9))/3,3),DRAWNULL);
AK1:=IF(K2=2,A-(A1-A*0.987),DRAWNULL);{原997}
{5日变色线}
越过成仙M240:MA(C,240),COLORGRAY,LINETHICK1;
M144:=MA(C,144),COLORWHITE,LINETHICK1;
M88:=MA(C,88),COLORLIGRAY,LINETHICK1;
越过有道M120:MA(C,120),COLORMAGENTA,LINETHICK1;
{越过强势M60:MA(C,60),COLORGREEN,LINETHICK3;}
M30:=MA(C,27),COLORGREEN,LINETHICK2;
M20:=MA(C,17),COLORMAGENTA,LINETHICK2;
M10:=MA(C,10),COLORWHITE,LINETHICK1;
M5:MA(C,3),COLORRED,LINETHICK3;
BB55:=ATAN((M5/REF(M5,1)-1)*100)*180/3.1416;
IF(BB55>30 AND M5>REF(M5,1), M5,DRAWNULL),COLORRED,LINETHICK3;
BB100:=ATAN((M10/REF(M10,1)-1)*100)*180/3.1416;
IF(BB55<0 AND M5<REF(M5,1), M5,DRAWNULL),COLORCYAN,LINETHICK2;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
{变色下插支撑线}
{YM:=EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,40);
YM1:=EMA(YM,1),NODRAW;
YM2:=EMA(YM1,2),NODRAW;
DRAWBAND(YM1,RGB(240,120,80),YM2,RGB(40,240,50));{变色条。如喜欢可以去掉括号}
{下插操作线}
{6、绿色新中操作线,无未来}
BR:=MA(CLOSE,13)+MA(CLOSE,13)-REF(MA(CLOSE,13),1);
分水岭R:=IF(MA(CLOSE,17)<BR,BR,MA(CLOSE,17)),COLORFF00FF,NODRAW;
YR:=分水岭R-(EMA(C,3)-分水岭R),COLORGREEN,LINETHICK2;
{多方上穿Y1变红色}
{IF(M5>REF(YR,1),YR,DRAWNULL),COLORYELLOW,LINETHICK2;}
OUTF:=CROSS(M5,YR);
{DRAWICON(OUTF,L*1.2,19);}
越过强势M60:MA(C,60),COLORWHITE,LINETHICK2;{60日均线};
B55:=ATAN((A15D/REF(A15D,1)-1)*100)*180/3.1416;
IF(55>30 AND A15D>REF(A15D,1), A15D,DRAWNULL),COLORCYAN,LINETHICK3;
B100:=ATAN((M5/REF(M5,1)-1)*100)*180/3.1416;
IF(B55<0 AND A15D<REF(A15D,1), A15D,DRAWNULL),COLORRED,LINETHICK3;
OUT1:=CROSS(M5,A15D);
IF(M5>REF(A3,1),A3,DRAWNULL),COLORYELLOW,LINETHICK5;{黄金支撑线}
DRAWICON(OUT1,L*0.98,13);
DRAWICON(OUTF,L*1.1,19);

通达信超级飓风眼主图指标公式

 

相关文章