载入中...
在线检测未来函数
载入中...

通达信趋势与股性指标公式

来源:Internet,编辑:股旁网,2019-01-21

REFLINE:2;
CS:=DMA(AMOUNT/(100*VOL),VOL/CAPITAL);
M20:=MA(C,20);
M30:=MA(C,30);
M2:=M20>REF(M20,1);
M3:=M30>REF(M30,1);
MCS:=CS>REF(CS,1);
TRD:=M2+M3+MCS>1;{趋势}
LBARS:=LLVBARS(L,21);
BARS:=IF(LBARS<13,13,LBARS);
ACT:SMA(MAX(ABS(C-O),ABS(C-REF(C,1)))/REF(C,1)*100,10,1),LINETHICK2;{活跃度}
YD:=ACT>LLV(ACT,13)*1.2;{异动}
A1:=ACT<2 AND NOT(YD);{弱}
A2:=ACT<2 AND YD;{异动}
A3:=ACT>=2 AND TRD;{强}
A4:=ACT>=2 AND NOT(TRD); {跌}
2,COLOR5E5E5E;
IF(A1>0,ACT,DRAWNULL),COLORBLUE,LINETHICK3;
IF(A2>0,ACT,DRAWNULL),COLORLIRED,LINETHICK3;
IF(A3>0,ACT,DRAWNULL),COLORRED,LINETHICK3;
IF(A4>0,ACT,DRAWNULL),COLORGREEN,LINETHICK3;
DRAWTEXT_FIX(1,0.05,0.02,1,'弱势'),COLORBLUE;
DRAWTEXT_FIX(1,0.05,0.17,1,'异动'),COLORLIRED;
DRAWTEXT_FIX(1,0.05,0.32,1,'强势'),COLORRED;
DRAWTEXT_FIX(1,0.05,0.47,1,'跌秃'),COLORGREEN;
DRAWTEXT_FIX(1,0.5,0.42,1,'短线:异动或强势——参与?!股性处于2以上比较活跃'),COLOR5E5E5E;

通达信趋势与股性指标公式

 

相关文章