载入中...
在线检测未来函数
载入中...

通达信五日金叉十日七档黄金分割主图指标公式

来源:Internet,编辑:股旁网,2015-07-20

M5:MA(C,5);
M10:MA(C,10);
A:=BARSLAST(CROSS(M5,M10));
T:=BARSLAST(CURRBARSCOUNT=CONST(A)+1);
D:=MIN(M5,M10);
STICKLINE(T>=0,REF(D,T),REF(D,T),6,0),COLORRED,LINETHICK2;
STICKLINE(T>=0,REF(D+D*0.198,T),REF(D+D*0.198,T),6,-1),COLORLIMAGENTA;
STICKLINE(T>=0,REF(D-D*0.198,T),REF(D-D*0.198,T),6,-1),COLORLIMAGENTA;
STICKLINE(T>=0,REF(D+D*0.382,T),REF(D+D*0.382,T),6,-1),COLORGREEN;
STICKLINE(T>=0,REF(D-D*0.382,T),REF(D-D*0.382,T),6,-1),COLORGREEN;
STICKLINE(T>=0,REF(D+D*0.5,T),REF(D+D*0.5,T),6,-1),COLORYELLOW;
STICKLINE(T>=0,REF(D-D*0.5,T),REF(D-D*0.5,T),6,-1),COLORYELLOW;
DRAWTEXT(T=0,REF(D,T)*1.02,VARCAT(VARCAT('中心价:',VAR2STR(REF(D,T),2)),'元')),COLORWHITE;
DRAWTEXT(T=0,REF(D+D*0.198,T)*1.02,VARCAT(VARCAT('压力1:',VAR2STR(REF(D+D*0.198,T),2)),'元'))COLORYELLOW;
DRAWTEXT(T=0,REF(D+D*0.382,T)*1.02,VARCAT(VARCAT('压力2:',VAR2STR(REF(D+D*0.382,T),2)),'元'))COLORYELLOW;
DRAWTEXT(T=0,REF(D+D*0.5,T)*1.02,VARCAT(VARCAT('压力3:',VAR2STR(REF(D+D*0.5,T),2)),'元'))COLORYELLOW;
DRAWTEXT(T=0,REF(D-D*0.198,T)*1.02,VARCAT(VARCAT('支撑1:',VAR2STR(REF(D-D*0.198,T),2)),'元')),COLORMAGENTA;
DRAWTEXT(T=0,REF(D-D*0.380,T)*1.02,VARCAT(VARCAT('支撑2:',VAR2STR(REF(D-D*0.382,T),2)),'元')),COLORMAGENTA;
DRAWTEXT(T=0,REF(D-D*0.5,T)*1.02,VARCAT(VARCAT('支撑3:',VAR2STR(REF(D-D*0.5,T),2)),'元')),COLORMAGENTA;

通达信五日金叉十日七档黄金分割主图指标公式

 

相关文章