载入中...
在线检测未来函数
载入中...

历史累计涨幅统计公式

来源:Internet,编辑:股旁网,2012-11-20

编写要求:

1、A:10日均线上穿60日均线的收盘价; 2、B:10日均线下穿60日均线的收盘价; 3、历史次数:上穿后再下穿为一次; 4、每次涨幅:A/B*100; 5、历史累计涨幅。

股旁网解答:

M10:=MA(C,10);
M60:=MA(C,60);
T1:=BARSLAST(M10<M60),NODRAW;
A:IF(T1>0,REF(C,T1-1),DRAWNULL);
T2:=BARSLAST(M10>M60);
B:IF(T2>0,REF(C,T2-1),DRAWNULL);
历史次数:SUM(CROSS(T2>1,0.5),0),NODRAW;
每次涨幅:IF(T1>0,REF((A-REF(B,1))/REF(B,1)*100,T1-1),DRAWNULL),NODRAW;
ZF:=(C-REF(C,1))/REF(C,1)*100;
历史累计涨幅:SUM(ZF,0),NODRAW; 

相关文章