载入中...
在线检测未来函数
载入中...

完善计算阶段累计成交量的累计曲线的公式

来源:Internet,编辑:股旁网,2012-09-05

编写要求:

以下是我求助老师帮我完善的公式,它把股票从上市来按每完成一次完全换手的位置标注出来,并计算出现在距最后一次完全换手的天数(公式中的天数1),距最后一次完全换手的累计成交量(公式中的累计成交量1),现在距最后一次完全换手的上一次完全换手的天数(公式中的天数2),现在距最后一次完全换手的上一次完全换手的累计成交量(公式中的累计成交量2)。 现在再次求助老师完善以下表达,1、现在距最后一次完全换手的上一次完全换手的再上一次完全换手的天数,和累计成交量(也就是成交量3及天数3)的表达方式。2、把累计成交量1、累计成交量2、累计成交量3的累计曲线画出来,在图形中,累计成交量3以前的累计曲线不表达出来,也就是说以现在距最后一次完全换手的上一次完全换手的再上一次完全换手为起点来划累计成交量曲线。现将插图发出,其要求已在图上注明。 原求助老师完善的公式如下: HSL1:= VOL*100/FINANCE(7)*100; HSL:=IF(BASE>=BARSCOUNT(C),0,HSL1);{BASE前的取值取0,相当于BASE后1天为起点} WCHS1:=SUMBARS(HSL,100); {完成换手,设置>99000是因为用FINANCE(7)计算换手率间隔WCHS1在上市前几天数据异常,直接置0。} WCHS:=IF(WCHS1>99000 OR WCHS1<0,0,WCHS1),LINETHICK3,COLORC000FF; BC:=BARSCOUNT(C);{上市到目前的天数} SH:=SUM(HSL,0);{上市到目前的总换手率} P:=INTPART(SH/100)*100;{换手满100%的次数} CDAY:=IF(P>REF(P,1),BC,0); {把最近一次完全换手后,累计换手达到25%,50%,75%,100%位置标识出来} CC25:=SH-REF(SH,BARSLAST(CDAY>0)); C25:=CROSS(SH-REF(SH,BARSLAST(CDAY>0)),25); C50:=CROSS(SH-REF(SH,BARSLAST(CDAY>0)),50); C75:=CROSS(SH-REF(SH,BARSLAST(CDAY>0)),75); {换手间隔} HSJG:= IF(CDAY>0 OR C50 OR C25 OR C75,WCHS,0); 成交量:VOL,VOLSTICK; DRAWTEXT(C25,V*1.03,'25'),COLORYELLOW; DRAWTEXT(C50,V*1.03,'50'),COLORYELLOW; DRAWTEXT(C75,V*1.03,'75'),COLORYELLOW; DRAWTEXT(CDAY>0, V*1.03,'100'),COLORWHITE; DRAWICON(CDAY>0, 0,3); 天数1:BARSLAST(CDAY>0),NODRAW; 累积成交量1:SUM(V,天数1), NODRAW; 天数2:REF(BARSLAST(CDAY>0),天数1+1)+天数1,NODRAW; 累积成交量2:SUM(V,天数2), NODRAW; 现求助老师按图上标注的间隔,写出每个相间的天数和相应的累计成交量,要画出相应的累计成交量的累计曲线,间隔以外的累计曲线应不显示。

股旁网解答:

 HS:V*100/FINANCE(7)*100,VOLSTICK;

HS1:=INTPART(SUM(HS/100,0));
HS2:=HS1!=REF(HS1,1) OR BARSCOUNT(C)=0;
HS3:=BARSLAST(HS2);
HS4:=SUM(HS,HS3+1);
S2:=REF(HS3,HS3+1);
S3:=REF(REF(HS3,HS3+1),HS3+1);
S4:=REF(REF(REF(HS3,HS3+1),HS3+1),HS3+1);
Q1:=BACKSET(ISLASTBAR,HS3+1);
Q2:=BACKSET(ISLASTBAR,S2+HS3+2);
Q3:=BACKSET(ISLASTBAR,S3+S2+HS3+3);
Q4:=BACKSET(ISLASTBAR,S4+S3+S2+HS3+4);
前数1:BARSLAST(Q1>REF(Q1,1))+1,NODRAW,COLORYELLOW;
前量1:SUM(HS,前数1),NODRAW,COLORYELLOW;
NOTEXT1:MA(HS,前数1),COLORYELLOW;
前数2:BARSLAST(Q2>REF(Q2,1))+1,NODRAW,COLORGREEN;
前量2:SUM(HS,前数2),NODRAW,COLORGREEN;
NOTEXT2:MA(HS,前数2),COLORGREEN;
前数3:BARSLAST(Q3>REF(Q3,1))+1,NODRAW,COLORMAGENTA;
前量3:SUM(HS,前数3),NODRAW,COLORMAGENTA;
NOTEXT3:MA(HS,前数3),COLORMAGENTA;
前数4:BARSLAST(Q4>REF(Q4,1))+1,NODRAW,COLORBLUE;
前量4:SUM(HS,前数4),NODRAW,COLORBLUE;
NOTEXT4:MA(HS,前数4),COLORBLUE;
 
STICKLINE(HS2,HS,0,2,0),COLORMAGENTA;
DRAWICON(HS2,0,3);
AA:=CONST(HHV(HS,120))*0.6;
DRAWTEXT(CROSS(HS4,25),AA,'25%'),COLORYELLOW;
DRAWTEXT(CROSS(HS4,50),AA,'50%'),COLORYELLOW;
DRAWTEXT(CROSS(HS4,75),AA,'75%'),COLORYELLOW;
DRAWTEXT(HS2,AA,'100%'),COLORMAGENTA;
STICKLINE(CROSS(HS4,25) OR CROSS(HS4,50) OR CROSS(HS4,75),HS,0,0,0),COLORYELLOW;
DRAWTEXT(Q1>REF(Q1,1),AA/2,'1次'),COLORYELLOW;
DRAWTEXT(Q2>REF(Q2,1),AA/2,'2次'),COLORGREEN;
DRAWTEXT(Q3>REF(Q3,1),AA/2,'3次'),COLORMAGENTA;
DRAWTEXT(Q4>REF(Q4,1),AA/2,'4次'),COLORBLUE;

相关文章