载入中...
在线检测未来函数
载入中...

把(资金进场和出击买卖)等5个选股指标合并在一起

来源:Internet,编辑:股旁网,2012-08-31

编写要求:

1. LOWV:=LLV(LOW,9); HIGHV:=HHV(HIGH,9); RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3); K:=EMA(RSV,3); D:=MA(K,3); CROSS(K,D); 2. VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2)); VARD:=(CLOSE=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1; 3. ZLCM:=EMA(WINNER(CLOSE)*70,3); SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3); ZZLKP:=ZLCM/(ZLCM+SHCM)*100; ZZLJJ:=EMA(ZZLKP,89); ZJLRQD:=ZZLKP-ZZLJJ; AA:=EMA(ZJLRQD,3); BB:=EMA(AA,5); CC:=AA-BB; 资金进场:CROSS(AA,BB); 4. (CLOSE-LOW)/(CLOSE-OPEN)>N OR (CLOSE-LOW)/(CLOSE-OPEN)<-N; N( 2 20 3) 5. MAC5:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926); M5:=MA(MAC5,5); AA:=PLOYLINE(CROSS(MAC5,M5),M5),COLORRED; XG:CROSS(MAC5,M5) AND AA

股旁网解答:

 LOWV:=LLV(LOW,9);

HIGHV:=HHV(HIGH,9);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
K:=EMA(RSV,3);
D:=MA(K,3);
公式1:=CROSS(K,D);
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
公式2:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
ZLCM:=EMA(WINNER(CLOSE)*70,3);
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;
ZZLJJ:=EMA(ZZLKP,89);
ZJLRQD:=ZZLKP-ZZLJJ;
AAA:=EMA(ZJLRQD,3);
BB:=EMA(AAA,5);
CC:=AAA-BB;
公式3:=CROSS(AAA,BB);
公式4:=(CLOSE-LOW)/(CLOSE-OPEN)>3 OR (CLOSE-LOW)/(CLOSE-OPEN)<-3; 
MAC5:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926);
M5:=MA(MAC5,5);
AA:=PLOYLINE(CROSS(MAC5,M5),M5),COLORRED;
公式5:=CROSS(MAC5,M5) AND AA<REF(AA,5);
公式1 OR 公式2 OR 公式3 AND 公式4 OR 公式5;
 

相关文章